Just bought C2, now preview isn't working

Bugs will be moved here once resolved.

Post » Wed Jul 15, 2015 3:14 am

Problem Description
Just bought C2 and upgraded to the most recent stable version (206 32 bit). My preview doesn't work anymore. Tried the LAN preview as well, and am getting no results. The localhost preview doesn't come up with any error message, and refuses to load anything (no splash loader screen), and LAN only comes up with "The connection was reset". Same error in both Firefox and Chrome.

Tried the obvious, restarts of Construct and browsers, restart computer, tried LAN preview, changed ports (tried multiple ports range from 49153 to 50001), changed firewall exception settings, completely disabled firewall, changed router settings for allowed range of ports, as well as IP , edited HOSTS file, ran as Admin. Also tried uninstall, installed the newest beta version (209), still no luck.

Super bummed since I finally just purchased the software. Any help would be great.




Operating System and Service Pack
Windows XP Service Pack 3

Construct 2 Version ID
206 Stable 32 bit, and 209 Beta 32 bit

Edit: Also no server software, no proxy or vpn, or anything. I had disabled and eventually uninstalled these while troubleshooting.
B
5
S
2
Posts: 32
Reputation: 493

Post » Wed Jul 15, 2015 3:33 am

Try to upgrade to Windows Vista or later.

AFAIK, Windows XP is not supported anymore for C2.
Twitter | Facebook | Instagram

If you play Puyo Puyo games, you can meet me at the Puyo Puyo English Community Discord: https://discord.gg/0k41S8ARwvY2iTIQ
B
104
S
24
G
11
Posts: 698
Reputation: 12,935

Post » Wed Jul 15, 2015 4:24 am

Thanks. I'm pretty sure XP is still supported. The idea of upgrading kinda makes me cringe.

Ran cmd, and netstat command for active connections, checked port 50000 and is listed as open and listening, cannot figure out what the problem is.

Edit: Tried DMZ option in router to bypass the routers on firewall settings to see if it was an issue, no luck.
B
5
S
2
Posts: 32
Reputation: 493

Post » Wed Jul 15, 2015 5:34 am

Well, ended up reverting to version 195, and it works now. Would still love to update though. Relieved I can keep working now, but still...
B
5
S
2
Posts: 32
Reputation: 493

Post » Wed Jul 15, 2015 7:30 am

It appears that MtnHermit is correct Xp is supported as minimum requirements
Minimum system requirements

•Windows XP Service Pack 3 or newer
•512 MB RAM
•1 GHz Processor
•A HTML5 compatible browser (see below)
•The latest version of your graphics card drivers

That is if this page is up to date
https://www.scirra.com/manual/6/system-requirements

Jim
B
16
S
4
Posts: 13
Reputation: 968

Post » Wed Jul 15, 2015 10:29 am

See troubleshooting Construct 2's preview server.

You really, really should upgrade from XP. It's well past Microsoft's own support, so it's becoming increasingly insecure; browser makers will sooner or later drop XP support too (so you'll end up with a frozen, aging version of Chrome at some point for example, and of course you cannot test IE11 or Edge with their radical changes); we ourselves may eventually drop support for XP because it's increasingly difficult to support such old systems.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143

Post » Wed Jul 15, 2015 4:42 pm

Thanks guys.

I went through the whole troubleshooting Construct 2's preview server"" guide, with no luck though.

I'll look into upgrading my operating system.
B
5
S
2
Posts: 32
Reputation: 493


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest