Page 1 of 2

keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 10:25 am
by Pixiefingers
I have tried everything I can think of, but I just cannot get my game to register the keyboard in an iFrame.

It works fine when I test it directly from C2, but as soon as it's online, the arrows won't work.

I have even set the Default controls to "No" and used W,A,S,and D. To no avail.

Tried adding a blank:

Keyboard -> On S pressed

I never had this problem before.

Any ideas?Pixiefingers2012-05-22 08:00:13

Re: keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 1:21 pm
by Ashley
You need to click in a game in an iframe before it will detect keyboard input. Maybe you need to do that?

Our Arcade uses games in iframes too, and we have the same problem, but I think users are pretty used to clicking inside things to get the keyboard input working. (You need to click a window in your OS before it gets keyboard input, too.)

Re: keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 1:45 pm
by Pixiefingers
tried clicking too. :-(Pixiefingers2012-05-21 13:45:26

Re: keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 1:46 pm
by Ashley
Can you link us to your site?

Re: keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 1:48 pm
by Pixiefingers
I already pulled it. But will reload it and pm the link as its a test site.

Re: keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 1:56 pm
by Pixiefingers
Sent

Re: keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 2:03 pm
by Pixiefingers
Controls are supposed to be W,A,S & D

Re: keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 2:19 pm
by Ashley
I remember @Tom needing to make adjustments on the Arcade to get keyboard input working properly when using an iframe... Tom, can you help here?

Re: keyboard controls not working (r90+r91))

PostPosted: Mon May 21, 2012 2:21 pm
by Pixiefingers
[QUOTE=Ashley] I remember @Tom needing to make adjustments on the Arcade to get keyboard input working properly when using an iframe... Tom, can you help here?[/QUOTE]

Then how come I had no problems with this one?

http://www.skillpod.com/games/play/spitbug

Re: keyboard controls not working (r90+r91))

PostPosted: Tue May 22, 2012 12:23 pm
by Pixiefingers
It seems to be a problem with setting the "Touch" to allow mouse input.