keyboard doesn't work on mac. after exporting..

Get help using Construct 2

Post » Sat Sep 19, 2015 8:29 pm

i just exported my game . and when i played on pc . it worked good. but when i tryied to play on mac the keyboard didnt work.
whenever i press any key it just give buz sound like it does.. if you use mac you would know., does any have or had similar prob in the past. need help...
B
5
S
1
Posts: 49
Reputation: 455

Post » Wed Sep 30, 2015 10:49 pm

Bump because I'm having this issue too.

Plugged in my gamepad and it worked fine but just the error tone for anything on keyboard.
B
42
S
11
G
1
Posts: 264
Reputation: 3,299

Post » Thu Oct 01, 2015 1:27 am

I should also mention that I copied my exported nw.js file to a flash drive and then from there to my mac. Potential permission errors?

I also did a super basic .capx and that worked fine after I clicked on the window. However my game requests fullscreen and jumps in to it and I think that is where the issue is. Looking in to it now.
B
42
S
11
G
1
Posts: 264
Reputation: 3,299

Post » Thu Oct 01, 2015 2:58 am

Okay so it's definitely related to going full-screen on mac in nw.js with my build. Game works fine and great windowed but the moment I full-screen it, it completely ignores all keyboard input. I feel like it thinks the window isn't in the forground?

I have a fullscreen request at the beginning of my game. It can also be toggled via esc. Even with the request disabled at the beginning and full-screen being toggled later, it still ignores the keypad.

Again - game works fine windowed and full-screen with gamepad.
B
42
S
11
G
1
Posts: 264
Reputation: 3,299

Post » Thu Oct 01, 2015 11:48 am

Thanks Mann , i will definitely try this.. thanks :P
B
5
S
1
Posts: 49
Reputation: 455

Post » Thu Oct 01, 2015 1:51 pm

@CodeArtOnline Hey I was browsing through the manual and saw that the nw.js object has a "set always on top" action. So I *think* if you set this action to trigger/true only while in full-screen, it may work. This is assuming that nw.js doesn't think that the fullscreen is in focus/on top. I'm at work right now or I'd try it out :roll:

I can definitely try it out tonight and get back to you.
B
42
S
11
G
1
Posts: 264
Reputation: 3,299

Post » Fri Oct 02, 2015 3:58 am

Image

@CodeArtOnline This worked for me!

-Add the nw.js object to your layout
-Request "always on top" while in fullscreen.

What I have pictured is my fullscreen toggle (pressing ESC). I also have a fullscreen request during "on start of layout" on my very first layout. If you do the same, add the "always on top" request there as well.

Note: I had to click inside the window for it to recognize the keyboard. After that, worked great!
B
42
S
11
G
1
Posts: 264
Reputation: 3,299

Post » Sun Oct 04, 2015 5:11 pm

Man ur a wizard :P thankssss i will try it out.. but it will work i can sense it .. Thankssssss a tonn
B
5
S
1
Posts: 49
Reputation: 455


Return to How do I....?

Who is online

Users browsing this forum: Cub3D, David181, yiuyiu6666 and 13 guests