Keys: not doing what I tell it to

Bugs will be moved here once resolved.

Post » Wed Jul 15, 2015 5:46 pm

Problem Description
____ A concise description of your problem here ____

The main problem is Construct is not doing what I tell it to. I've done everything I could to get the touch keys to work but they won't work, I've checked and tried everything I could possibly think of.

Attach a Capx
____ Upload a Capx to this post ____

http://public.justcloud.com/e5cnb3yiog.88126043
My file is stored on cloud service.

Description of Capx
____ Concise description of what this CapX does ____

-The touch keys on my game works just fine on the 1st level, but it does not work at all on level 2, for no apparent reason. I've done nothing wrong, and yet it doesn't work properly, and there's no way to get the touch screen keys to work in level 2. Some of the swim animations don't work either.
-The touch keys are located on the upper right corner. The movement keys are in the game event sheet.
-I've done nothing wrong, I've tried everything to get the touch keys to work but nothing works.

Steps to Reproduce Bug
  • Step 1
  • Step 2
  • Step 3 etc.


Observed Result
____ What happens? ____

When I touch the arrows on the upper right corner (on level 2), the character does not do anything, just ducks when using the lower arrows.
It works just fine on level 1.

Expected Result
____ What do you expect to happen? ____

When I touch the arrows, on level 2, the character is supposed to move, the upper arrows are for jumping, the middle ones are just for running.

Affected Browsers
  • Chrome: (YES/NO)
  • FireFox: (YES/NO)
  • Internet Explorer: (YES/NO)

It's like that on all browsers.

Operating System and Service Pack
____ Your operating system and service pack ____

I'm using Windows 7, 64 bit PC.

Construct 2 Version ID
____ Exact version ID of Construct 2 you're using ____

I'm using the latest (non beta) version of Construct 2.
B
12
S
3
Posts: 89
Reputation: 1,566

Post » Thu Jul 16, 2015 10:39 pm

You don't have any instances of liquid nor ladders in level 2, so the events won't run. I'm not sure if that's a bug.
B
9
S
2
Posts: 19
Reputation: 660

Post » Thu Jul 16, 2015 10:53 pm

Thanks. I'll try that.
Done.

I just put in ladders & water in level 2, that solved the main problem. I probably wouldn't have thought of that myself. Turns out it's not a bug after all.
B
12
S
3
Posts: 89
Reputation: 1,566


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests