KitKat 4.4 issues?

Discussion and feedback on Construct 2

Post » Fri May 30, 2014 1:27 am

Hi All,

Have posted a thread here...

stackoverflow DOT com/questions/23932708/loading-html5-js-into-webview-fails-on-nexus7-running-kitkat-but-ok-on-phone-ru

but basically, we have loaded a WebView into a native Android app loading our Construct2 created game URL.
This works fine on an older device running Gingerbread , but fails to load on a Nexus7 running Kitkat.
This also works fine on iOS devices as well (native iOS app, loading game in a webview)

Has anyone else experienced this?
Anything I might be doing wrong in the exporting process?
B
4
Posts: 18
Reputation: 230

Post » Fri May 30, 2014 7:11 am

just a bit more info..

developer.chrome DOT com/multidevice/webview/overview#does_the_new_webview_have_feature_parity_with_chrome_for_android_

the problems we face are that Construct 2 looks like it's generating code which will work in the chrome browser but not in an embedded WebView.
For example I'm guessing Construct 2 is using WebAudio to play the music, which is why I hear it in Chrome but not in the app since WebAudio is one of the features not currently supported in WebView.

anyone experienced something similar?
B
4
Posts: 18
Reputation: 230

Post » Fri May 30, 2014 7:27 am

If you search for 'Webview' you'll find a couple of threads, this has some info:

https://www.scirra.com/forum/say-hi-to-chrome-span-class-posthilit-webview-span-in-4-4_p713429?#p713429

It looks like webview has a few things it needs to implement.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
84
Posts: 5,388
Reputation: 58,458


Return to Construct 2 General

Who is online

Users browsing this forum: kiki4construct and 5 guests