Lag after scrolling

For questions about using Classic.

Post » Sat Jan 24, 2009 11:19 pm

I've set a game I'm making to scroll downward but after a while it lags from 60fps to 30fps even if theres nuthing there. Can anyone sujest a cause?

http://nanoware.no-ip.biz/a1.cap
-Please don't steal
B
2
G
4
Posts: 69
Reputation: 1,188

Post » Sat Jan 24, 2009 11:45 pm

hovers around 85fps for me all the time, even to bottom
B
2
S
2
G
4
Posts: 254
Reputation: 1,958

Post » Sat Jan 24, 2009 11:55 pm

It maintains a consistent 75 FPS for me.
Moderator
B
99
S
37
G
19
Posts: 1,584
Reputation: 17,842

Post » Sat Jan 24, 2009 11:57 pm

Hmm... Odd.
B
2
G
4
Posts: 69
Reputation: 1,188

Post » Sun Jan 25, 2009 12:02 am

if the scrolling is always one-way (in other words, you don't need to scroll back up ever) you could destroy objects that are no longer visisble/needed and free up some resources.
B
2
S
2
G
4
Posts: 254
Reputation: 1,958

Post » Sun Jan 25, 2009 12:04 am

i set it to 1 instead of 0.5 and now no lag.
B
2
G
4
Posts: 69
Reputation: 1,188

Post » Sun Jan 25, 2009 12:09 am

Wait a minute, I remember this kind of thing happening with someone else not to long ago. I'm pretty sure it has to do with VSYNC, particularly when the framerate drops below the refresh rate of your monitor. The framerate will half itself then.

Here's the topic where Ashley explains it.
Moderator
B
99
S
37
G
19
Posts: 1,584
Reputation: 17,842

Post » Sun Jan 25, 2009 4:17 am

The .cap file linked in the post is no longer online.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,620


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 7 guests