Page 1 of 1

Libpng Vulnerability in Google Play

PostPosted: Wed Jun 15, 2016 5:48 pm
by PiriB
Hi everyone,

Today I received a message in Google Play saying that my game (link is in my signature) has Libpng Vulnerability. Full message:

Your app is using a version of libpng containing a security vulnerability. Please see this Google Help Center article for details, including the deadline for fixing the vulnerability.

I googled this, but could not find anything around. I built using Cocoon.io and latest Construct 2 r227 if that is of importance.

Anyone has any idea how to fix this/had the same issue?

Re: Libpng Vulnerability in Google Play

PostPosted: Thu Jun 16, 2016 2:35 am
by takamoto
rez

Re: Libpng Vulnerability in Google Play

PostPosted: Thu Jun 16, 2016 11:01 am
by cooltaby
same issue here, any update, was updated few games now needs to update it all :( @ludei @Ashley ?

Re: Libpng Vulnerability in Google Play

PostPosted: Thu Jun 16, 2016 11:36 am
by PiriB
@cooltaby , I will presume that it is the Construct 2 using the old Libpng reference library.

@Ashley , could you please take a look at this?

Re: Libpng Vulnerability in Google Play

PostPosted: Thu Jun 16, 2016 5:07 pm
by onur
I just get the same mail. I build my game via crosswalk if i am not wrong. What should we do?

Re: Libpng Vulnerability in Google Play

PostPosted: Thu Jun 16, 2016 5:10 pm
by cooltaby
@PiriB take a look at this cocoon.io is updating their libs https://forums.cocoon.io/t/libpng-warni ... gle/3017/8 .

Re: Libpng Vulnerability in Google Play

PostPosted: Thu Jun 16, 2016 5:24 pm
by Ashley
I think you will just need to rebuild the app with the latest version of Crosswalk/Cocoon/whatever you're using. If that doesn't work you might need to wait for them to update...

Re: Libpng Vulnerability in Google Play

PostPosted: Thu Jun 16, 2016 7:46 pm
by PiriB
Whoops, @cooltaby , @Ashley thanks. I will update the thread as soon as we get an update on this from Cocoon.