Linux having problems running the game only in steam.

Get help using Construct 2

Post » Sat Jan 16, 2016 12:51 pm

People can play my game on linux running the same game files outside of steam but they get errors when trying to play it through steam itself.
Is there something I have to do to make it run properly when going through steam?

some comments I got:

"yes, I can reproduce this (gentoo ~amd64, xfce4, nvidia-drivers-361.18, GTX 980 Ti).
does nothing when launched from steam, works from commandline.
commandline snip:
$ ./eternalstep
[19075:0115/165216:ERROR:browser_main_loop.cc(170)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki ... evelopment for more information on developing with the sandbox on.
[19075:0115/165219:INFO:CONSOLE(0)] "dopplerFactor is deprecated and will be removed in M45 when all doppler effects are removed", source: (0)
[19075:0115/165220:WARNING:shared_memory_posix.cc(385)] Shared memory creation failed; out of file descriptors"

"One interesting thing I noticed is that the game is technically running, but there is no window. I have to kill it from my task manager in order to attempt to start it again. I also noticed that when I run it from the console I get this message repeated a lot right when it loads.
[6744:1218/181911:WARNING:shared_memory_posix.cc(385)] Shared memory creation failed; out of file descriptors

I had plenty of memory available at the time I ran this"
B
12
S
4
G
1
Posts: 137
Reputation: 1,519

Return to How do I....?

Who is online

Users browsing this forum: skrotar, yme, Youtopize and 12 guests