Loading problem on Mobile [Android]

Discussion and feedback on Construct 2

Post » Thu Sep 14, 2017 1:30 pm

Hello,

I am preparing my game http://44.wz32.net to for Android. Game is quiet big 110 MB+. I've build mobile android version using Cordova.
In general game works but I have big problem with loading. In most cases loading process crash and bar change color from blue to red. I need to kill app and try once again many times. Hit rate is 1/10. Test phone is Samsung S5 Active.

Do you know what is the cause and why sometimes it works sometimes not ? Did you encounter similar problem ?

Regards
Sventevith
B
9
S
2
G
1
Posts: 53
Reputation: 748

Post » Thu Sep 14, 2017 2:41 pm

I assume CocoonIO? what cocoon plugins are you using? and what web engine?
B
98
S
32
G
16
Posts: 1,204
Reputation: 16,715

Post » Thu Sep 14, 2017 3:40 pm

- Cordova CLI,
- webwiev,
- Android 5.0
- Samsung galaxy S5.
B
9
S
2
G
1
Posts: 53
Reputation: 748

Post » Thu Sep 14, 2017 6:50 pm

cool game, I played the web version.

The only thing that sticks out to me I would say is you have really big graphic files with lots of frames of animation as well as big static background images. I know that's not the answer you want to hear.. since that is a design issue.

do you know what your memory footprint is? I assume once loaded the performance is okay right?
B
98
S
32
G
16
Posts: 1,204
Reputation: 16,715

Post » Sat Sep 16, 2017 8:24 pm

I played the web version as well. Great game! (the mobile one just said coming soon)


HTH: When you get it available in mobile, use Chrome debug (F12) and set to mobile phone, goto network tab and you can inspect timings for all requests.
B
9
S
4
Posts: 21
Reputation: 719

Post » Mon Sep 18, 2017 8:05 pm

jobel wrote:cool game, I played the web version.

The only thing that sticks out to me I would say is you have really big graphic files with lots of frames of animation as well as big static background images. I know that's not the answer you want to hear.. since that is a design issue.

do you know what your memory footprint is? I assume once loaded the performance is okay right?


Yes, when game is loaded then no problem. Foot print is ~350+ MB Ram. I am not able to change design :( Year ago webwiev was was not stable and game crash during game play now it is ok but i encounter problem with loading.
B
9
S
2
G
1
Posts: 53
Reputation: 748

Post » Mon Sep 18, 2017 8:06 pm

htmlgames wrote:I played the web version as well. Great game! (the mobile one just said coming soon)


HTH: When you get it available in mobile, use Chrome debug (F12) and set to mobile phone, goto network tab and you can inspect timings for all requests.


Yes I've tried but chrome doesn't see my Samsung S5 Active so I am not able to debug. I've tried many tricks from web (drivers etc) but still I have a problem.
B
9
S
2
G
1
Posts: 53
Reputation: 748

Post » Tue Sep 19, 2017 8:05 pm

As a test could you drastically reduce all you graphics (using higher compression) and see if that effects anything?

EDIT: Also are you loading everything locally?
B
9
S
4
Posts: 21
Reputation: 719

Post » Thu Sep 21, 2017 10:49 am

Yes, I've built new version using highest (brute) mode and now all graphics is ~94 MB without compression 110. Today I am going to test. I am resolving also problem with debug using chrome. For example game doesn't work for IE 11 because of error with sound loading. Maybe on Android I have similar problem but without debug is hard to say.
B
9
S
2
G
1
Posts: 53
Reputation: 748

Post » Thu Sep 21, 2017 1:25 pm

Good Morning.
I did not see any problems in Chrome, the delay in loading may be due to the size of the images in Sprites.
Huemerson
B
22
S
16
G
21
Posts: 108
Reputation: 16,867

Next

Return to Construct 2 General

Who is online

Users browsing this forum: AnimH01, Refeuh and 7 guests