Loading Sprites Characters in Different Layouts

Get help using Construct 2

Post » Thu Aug 07, 2014 9:01 pm

CAPX: https://www.dropbox.com/s/2rmfa0sqosnzy ... 201-1.capx

I have two layouts (marked with an "L" in each name; likewise an "E" for each event sheet...makes things easier to identify).
In the "L Maze D West" layout, you'll see the LostSoul object (in the Characters folder in the editor) pulsating with a couple of active effects. Below the LostSoul is the TileGlow object which changes color based on the player movement. So far everything in this layout is working properly.

The problem I'm having is in setting up details for the "L Maze MercuryUs" layout and its related event sheet. The LostSoul character isn't behaving as it does in the "L Maze D West" layout, even though I've added actions to the "On Start of Layout" event line (see event sheet "E Gen Cntls Anims").

You can see a little bit of the LostSoul character in the "L Maze MercuryUs" layout when you Run it, but obviously it's not acting as it does in the other layout. I cannot figure out why... Can someone help me see what probably should be obvious? Thank you!

(Also, I intentionally disable the "Scroll To" behavior in the "E MercuryUs" event sheet. That's not a mistake.)
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
141
S
24
G
8
Posts: 790
Reputation: 15,119

Post » Fri Aug 08, 2014 2:21 pm

*bump*
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
141
S
24
G
8
Posts: 790
Reputation: 15,119

Post » Fri Aug 08, 2014 3:12 pm

It's not clear what you mean by "it's not acting as it does in the other layout". Other than the 8-direction Default controls set to No, I don't see a difference.
ImageImageImage
B
71
S
22
G
247
Posts: 3,753
Reputation: 137,552

Post » Fri Aug 08, 2014 6:30 pm

@blackhornet - Strange. So on the "D West" layout, the LostSoul object appears as a series of rings flowing inward...and then ALSO flowing inward on the "MercuryUs" layout?

For me, on the "MercuryUs" layout, the TileGlow object still changes colors, but as different colors than on the "D West" layout. AND, the TileGlow object seems to be ON TOP of the LostSoul, even though TileGlow is on a lower layer. Despite using the SAME parameter values in the event sheet upon the start of both layouts, I get two different outcomes... I'll set up a comparison picture to show you what I'm getting since it seems you're not seeing any noticeable difference.
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
141
S
24
G
8
Posts: 790
Reputation: 15,119

Post » Fri Aug 08, 2014 6:54 pm

Image
Well, NOW the LostSoul object is appearing more on top of the TileGlow object. But the effects are still not the same as that on the "D West" layout.
Both are at a stand still, so the TileGlow object should appear red. Obviously the color on the right (layout "MercuryUs") isn't
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
141
S
24
G
8
Posts: 790
Reputation: 15,119

Post » Fri Aug 08, 2014 10:17 pm

Set Unbounded scrolling on "L Maze MercuryUs", don't disable scrolling. 8-direction Default controls = Yes.
ImageImageImage
B
71
S
22
G
247
Posts: 3,753
Reputation: 137,552

Post » Sat Aug 09, 2014 1:38 pm

That seems to have done the trick! Thank you! I'll let you know if anything else seems off from what I'm trying to accomplish. Thank you once again!
I'm seeking Narnia. Who wants to come with me! Aslan is on the move!
B
141
S
24
G
8
Posts: 790
Reputation: 15,119


Return to How do I....?

Who is online

Users browsing this forum: GrogIsGood and 5 guests