Loop is not working well

Bugs will be moved here once resolved.

Post » Wed Oct 17, 2012 8:34 am

Hello everyone , I try to make a loop which is generates a random number (from 1 to 24)for each 3 seconds and display the sound with match the number. Somehow the loop can't work as I want. The time between each step sometime long ( more than 5 or 6 seconds) or short. And the loop wont' stop after 5 tries at i set.
https://www.dropbox.com/s/x1qxyu0adsbdqa4/Project.capx
Thank you for help.
Edit: Sorry, my bad, removed all the behaviors.lthuu2012-10-18 03:46:58
B
3
Posts: 4
Reputation: 490

Post » Wed Oct 17, 2012 11:38 am

can u remove all the 3rd party behaviours and then reupload your capx.. then i could check it
B
12
S
3
G
4
Posts: 23
Reputation: 3,682

Post » Wed Oct 17, 2012 3:06 pm

Please see how to report bugs - we can't help with bug reports using third party plugins. Closing.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Thu Oct 18, 2012 8:13 am

https://www.dropbox.com/s/x1qxyu0adsbdqa4/Project.capx
The third time, remove all unnecessaries.
B
3
Posts: 4
Reputation: 490

Post » Mon Oct 22, 2012 2:42 pm

I can't see enough evidence this is a Construct 2 bug and not just a mistake in your events. Please resubmit a minimal .capx made from scratch with no events or objects not directly related to the problem if you feel this is still a Construct 2 bug.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Tue Oct 23, 2012 3:39 am

Thank Ashley for answering me, finally solved my problem. Because the random numbers sometime duplicated and the play sound condition only trigger once so it make loop seem longer on each run. About the tries variable, forgot to set static to it so it will reset when a number is generated. This is not a bug but a mistake, thread can close. :D
Best regard.
B
3
Posts: 4
Reputation: 490


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests