M4A converter of C2 doesn't work well with small files

Bugs will be moved here once resolved.

Post » Thu Jul 31, 2014 8:17 am

Problem Description
when importing a sub 0.2 second .wav (this might vary a bit), and when C2 converts it into m4a format for Ejecta and ipads and safari, it cuts out the beginning of the sound, or inserts just silence.


Steps to Reproduce Bug
  • Get a sub 0.1 second audio wav
  • import into C2
  • Open with Ejecta or in Safari

Observed Result
No sound, or muffled sound

Expected Result
There to be a sound.

Affected Browsers
  • Chrome: (NO)
  • FireFox: (NO)
  • iOS on Ejecta (YES)

Operating System and Service Pack
Windows7 with parallels and OSX newest

Construct 2 Version ID
Release 175
B
39
S
6
G
1
Posts: 306
Reputation: 2,948

Post » Mon Aug 04, 2014 4:04 pm

Closing as won't fix, there's not much we can do about this, we don't make the AAC encoder and for patent reasons we would have to pay fees to include a different encoder. Workaround: encode .m4as yourself with your own encoder.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143

Post » Mon Aug 04, 2014 5:40 pm

@damjancd I have found Audacity to be extremely useful in situations where it is difficult for C2 to convert audio files: http://audacity.sourceforge.net/
ImageImageImageImage
B
62
S
19
G
51
Posts: 633
Reputation: 30,836

Post » Tue Aug 05, 2014 12:20 am

@DatapawWolf I don't have a problem since I extend the snippets of sound to 1 second so they work and convert stuff in CC Audition. it supports m4a conversion.

Ashley, ok, just wanted for folks to know about this then ;)
B
39
S
6
G
1
Posts: 306
Reputation: 2,948


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest