m4a sound files not playing in Intel XDK?

Get help using Construct 2

Post » Fri Feb 19, 2016 6:39 pm

In my game, I have imported both ogg files and m4a files but I can only play the ogg files inside C2 because the m4a options do not show up in the list. When I export and try debugging on my iPhone, no sounds are played even though I have the m4a files in construct 2. Any ideas on how I can fix this?
B
37
S
14
G
3
Posts: 263
Reputation: 4,270

Post » Fri Feb 19, 2016 6:55 pm

Update: the sound plays when headphones are plugged into the iOS device but don't play without headphones or earphones. I still don't know why the sound isn't playing when there aren't earphones plugged in.
B
37
S
14
G
3
Posts: 263
Reputation: 4,270

Post » Fri Feb 19, 2016 9:30 pm

HZGaming wrote:Update: the sound plays when headphones are plugged into the iOS device but don't play without headphones or earphones. I still don't know why the sound isn't playing when there aren't earphones plugged in.

Make sure your iOS is not in mute (check the slider on the side of the iPhone or Control Center for an iPad).
B
32
S
7
G
4
Posts: 397
Reputation: 4,589

Post » Fri Feb 19, 2016 10:42 pm

@grigrizljac oh yes that solved the issue. Thank you! Hahaha I'm sure however that you're aware of the audio distortion on iOS devices which is a shame. I'm considering releasing my games with minimal sounds. I'm also asking around on the intel forums to hopefully find a solution.
B
37
S
14
G
3
Posts: 263
Reputation: 4,270


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 15 guests