Mac nodewebkit broken due to massive input delay

Discussion and feedback on Construct 2

Post » Tue Aug 05, 2014 2:23 am

This has been pointed out here in the "closed bugs" section since it's a nodewebkit issue: mega-input-delay-bug-on-mac-os-node-webkit_t109328

Thought it might be useful to post it in the open as well, so that people are aware of this bug. Currently this leaves only the Windows nodewebkit exporter as functional at the moment.

Personally, with my game there's a 1 minute delay on the mouse movement/clicking. Which makes my game unplayable.

Here's a simple .capx that shows the issue if you want to compile it for your mac to see the input bug delay in action: https://copy.com/99TtMwBZ7QKekmNS
B
149
S
75
G
20
Posts: 1,791
Reputation: 22,695

Post » Tue Aug 05, 2014 1:53 pm

Thanks for the post. I wasn't aware of it, and I'm very glad to know.

So, Linux export is broken, Mac export is broken... It really sucks : /
Image | @AurelRegard on twitter
B
19
S
6
G
1
Posts: 307
Reputation: 2,500

Post » Tue Aug 05, 2014 1:58 pm

We really need some way to put pressure on the NW people, or even get someone working on our own fixes (it's open source, right?) because this is ridiculous.
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,689

Post » Tue Aug 05, 2014 2:32 pm

Well its been said plenty of times before. I know Ashley just says well publish it to the web and charge people to play instead but thats not really an answer.
B
48
S
16
G
9
Posts: 1,098
Reputation: 11,197

Post » Tue Aug 05, 2014 2:38 pm

A web build is not an option - it lacks authenticity and most of all it disallows distribution like Steam. Plus, there are a bunch of Chrome bugs involving music loading that flat-out prevents a Chrome build for me.
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,689

Post » Tue Aug 05, 2014 2:44 pm

@sqiddster

"it lacks authenticity and most of all it disallows distribution like Steam. " I agree,

Chrome bugs that dont manifest themselves in Node too ?
B
48
S
16
G
9
Posts: 1,098
Reputation: 11,197

Post » Tue Aug 05, 2014 3:14 pm

It may or may not be relevant.
I made a bit of a research.
For those that experience this delay on Mac, what Keyboard/Mice have you used?
- Conti
"It's done when it's done"

Shadows of War
Buy on Steam ;)
B
24
S
10
G
7
Posts: 253
Reputation: 4,931

Post » Fri Aug 08, 2014 12:21 pm

Heads open: This is still an issue in the latest Construct 2 build 176, which updated node-webkit to v0.10.1.
B
149
S
75
G
20
Posts: 1,791
Reputation: 22,695

Post » Fri Aug 08, 2014 4:02 pm

hmmmm...
My professional Royalty Free Music at Scirra Assets Store
--------------------------------
Specs: i5 2500, 16gb of ram, gtx 770, win 7, Focusrite Scarlett 8i6, Mackie mr8mk2, Alesis 320, browsing the net on chrome.
B
89
S
30
G
22
Posts: 1,985
Reputation: 20,099

Post » Fri Aug 08, 2014 4:09 pm

Ugh. Do the NW developers know about the issue? Do they have a simple test case?

I think a problem we face when dealing with them is that it's probably hard for them to find a bug amidst all of C2's boilerplate - some sort of clean repro would probably be more helpful? I don't have the skills to do that however. Anyone here have those abilities?
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,689

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 21 guests