Re: MagiCam Plugin - v1.43 BETA(Updated 12/10)

Post and try out addons that are currently in development.

Post » Sun Feb 06, 2011 5:45 pm

Alright, new question: I'm trying to get my camera to behave exactly like Super Mario World's, but there's one part of it I can't get right. It operates the same as MagiCam using margin scrolling, except when SMW starts scrolling, it moves ahead of Mario so roughly 60% of the screen is in front of him.

I can set it up one way or the other -- it can follow him using margins, so that there's an area in the middle where there's no scrolling, or it can follow 60% ahead of him. I can't really find a way to combine them the way I want to. Any ideas? :?
B
20
S
9
G
6
Posts: 607
Reputation: 6,112

Post » Sun Feb 06, 2011 5:51 pm

Yeah, I realized after the fact that margin scrolling isn't quite like Mario scrolling. I'll have to fiddle around with it to see if I can make a work around.
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Wed Feb 09, 2011 7:14 pm

No relative behavior to the system's values possible?
Image
B
23
S
8
G
10
Posts: 1,820
Reputation: 8,242

Post » Wed Feb 09, 2011 7:23 pm

[quote="tulamide":2wy8m3pd]No relative behavior to the system's values possible?[/quote:2wy8m3pd]
It's possible -- feasible, even -- but it would take a good amount of work, and I don't have much time these days between school and work.
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Wed Feb 09, 2011 7:39 pm

Ah, I see. Thanks for your answer, I do totally understand if it's too much work for the time you have :)
Image
B
23
S
8
G
10
Posts: 1,820
Reputation: 8,242

Post » Thu Feb 17, 2011 9:09 am

Thanks!
Going to test it.
B
16
S
5
G
7
Posts: 599
Reputation: 5,000

Post » Sat Mar 05, 2011 11:28 pm

Thanks for the great plugin. I'm in the process of converting over to it, and smooth map scrolling works great. However I can't get the minimap movement working.

Previously on a Left mouse button down event I had System Scroll to X set to:
[code:3azkt0mu]DisplayWidth*0.5 + Minimap.MapToLayoutX(Minimap.Width - (Minimap.Width / (ScrollXRight - Minimap.X) + (ScrollXRight - MouseX)))[/code:3azkt0mu]

A debug display of this equation gives an output of 0 to 4000 depending on the position of the mouse over the minimap (the layout size is 4000). This works fine. And if I set the X position of MagiCam to say 2500 it works fine as well. But when I try setting the X position of MagiCam to the above equation instead of System Scroll to X, it jumps all over the place. Any ideas on what's happening?
B
9
S
2
G
3
Posts: 75
Reputation: 1,964

Post » Sun Mar 06, 2011 12:17 am

@Khalan - If you don't mind sending me a CAP file with the problem, I'll check it out for you.
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

Post » Mon Mar 07, 2011 2:27 am

Any luck with looking at the cap file I sent you yesterday? (if you had the time to check it)
B
9
S
2
G
3
Posts: 75
Reputation: 1,964

Post » Mon Mar 07, 2011 3:37 am

Just to clarify, you're wanting the view to jump to the location that you click on on the map, correct?
Moderator
B
98
S
37
G
19
Posts: 1,584
Reputation: 17,817

PreviousNext

Return to Work-in-progress addons

Who is online

Users browsing this forum: No registered users and 0 guests