Main menu breaks game :(

Get help using Construct 2

Post » Tue May 07, 2013 7:32 pm

Hi there, Ive had help making this game but ive got the workings of construct down now.

Here's my current project to help make this more clear:

Ive created a 10(x3) level question based game, it includes pictures (for each questions answer) and 3 buttons for each answer, when the correct button is clicked, it adds +1 to "correct" which is the global variable and then it moves onto the next question whilst making certain objects invisible and others visible. (When the wrong button is clicked the image is destroyed and a (try again) text is displayed)

It gets all the way to 10 then goes back to 0, this is where my main menu is(global 0). In my menu I need 3 buttons:
1. For level 1
2. For Level 2
3. For level 3

My questions answers at this point in the global variable are invisable until the first question of any level. So I added new buttons just for selecting each level and made them on click +1 to Global, But whenever I do this, and try to run the game, it comes out white and fails to work at all. The only cure I've found is to undo, but I don't have a working menu...   

So I've made the first level (Global = 1-10)
The second will start at 11 and the 3rd at 21,
The last correct question button of each level referrers back to the menu.

So, my question is, does anyone know what i'm doing wrong? My only guess is that the global variable code is conflicting with itself...

Many thanks for any replies and help!!

Posts: 14
Reputation: 514

Return to How do I....?

Who is online

Users browsing this forum: Google [Bot], Taweel, Tigeri102 and 0 guests