Major Game Slowdown

Bugs will be moved here once resolved.

Post » Tue May 15, 2012 3:40 pm

Before my game was running at full speed in the editor but for some reason it lags when I'm trying to do my work inside construct 2. What could be causing this. Any other game or prototype i worked on has ever done this. I have to use the schools computers because my computer is too slow now. It's so strange.

I am only using 1 event sheet for about 15 layouts. I guess that can cause lag.
B
22
S
5
G
3
Posts: 194
Reputation: 5,855

Post » Tue May 15, 2012 4:36 pm

Please see how to report bugs. Can you share the affected .capx and your full system spec?

Also I'm not clear on exactly what the problem is: is it the editor that runs slowly, or the game? Is it only the game that runs slowly while you're also working in the editor?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528

Post » Tue May 15, 2012 4:47 pm

the editor is running slowly.
B
22
S
5
G
3
Posts: 194
Reputation: 5,855

Post » Thu May 17, 2012 1:41 pm

Does it run faster if the game is not running at the same time?

Can you also provide your full system spec?Ashley2012-05-17 13:41:14
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528

Post » Fri May 18, 2012 8:11 pm

The editor itself runs like buttttt. But only with this specific game. All my other prototypes run like a charm.



       Machine name:
   Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.120401-1505)
           Language: English (Regional Setting: English)
System Manufacturer: Alienware
       System Model: M11x
               BIOS: Ver 1.00 A05
          Processor: Genuine Intel(R) CPU           U7300 @ 1.30GHz (2 CPUs), ~1.7GHz
             Memory: 2048MB RAM
Available OS Memory: 1976MB RAM
          Page File: 2562MB used, 1391MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.01.7600.16385 32bit Unicode

------------
B
22
S
5
G
3
Posts: 194
Reputation: 5,855

Post » Fri May 18, 2012 8:12 pm

is sharing 1 event sheet a bad thing?
B
22
S
5
G
3
Posts: 194
Reputation: 5,855

Post » Fri May 18, 2012 8:16 pm

http://dl.dropbox.com/u/11360597/MainFile_postupdate.capx
B
22
S
5
G
3
Posts: 194
Reputation: 5,855

Post » Mon May 21, 2012 2:26 pm

From performance tips in the manual as a common cause of poor performance:

[quote]Using Sprites instead of Tiled Backgrounds
Creating too many objects can cause slowdowns, and a common mistake is to use grids of Sprite objects instead of Tiled Background objects. For example, a 20x20 grid of sprites has 400 objects, which is a significant impact on the object count. A single tiled background can replace the grid of sprites and it only counts as a single object. Tiled backgrounds are specially optimised for repeating their texture so in this case it is literally 400 times more efficient than the grid of sprites. Always use Tiled Backgrounds instead of repeating Sprites wherever possible.[/quote]

What you've done is *extremely* inefficient. Always, always always used tiled backgrounds when you have tiled images!! Closing as not a bug.Ashley2012-05-21 14:26:23
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest