Making joints stay still

Get help using Construct 2

Post » Sun May 26, 2013 9:46 pm

I seem to have an issue with physics joints. I created a rope using Yann's method from this thread, and the rope works fine, but for some reason it doesn't sit still. It just kind of tweaks out from the start (as if it's trying to connect the bottom of the first "rope" part to the ceiling instead of the top of the first rope part). I have the gravity set to 80 and the density of the rope 0.1.

Here is the code I'm using:



I'm also having an issue trying to "attach" the player to the rope. As you see, I've created an "attacher" sprite on the final piece of the rope, but everytime I attach the player to the rope part by joints, it tweaks and spas' out even more.

Any ideas on why this is happening?

Thanks.

B
22
S
3
Posts: 451
Reputation: 2,135

Post » Tue May 28, 2013 4:38 am

Any help on this would be greatly appreciated. Here's a CAPX to see what's going wrong.

https://dl.dropboxusercontent.com/u/28104568/Vines.capx
B
22
S
3
Posts: 451
Reputation: 2,135

Post » Tue May 28, 2013 5:46 am

Try increasing the linear/angular damping values?
B
7
S
1
Posts: 74
Reputation: 1,232

Post » Tue May 28, 2013 6:40 am

@mutuware - I've tried changing all of the values - they don't seem to fix it. It's almost as if the "if loopindex = 0" is instead counting the 2nd created vine as the joint point for the ceiling.
B
22
S
3
Posts: 451
Reputation: 2,135

Post » Tue May 28, 2013 6:26 pm

I completely do not get this - no matter what I do, these things are just spazzing out. I've tried the old fashioned way of creating individual pieces and linking them all together, but I get the same exact results.
B
22
S
3
Posts: 451
Reputation: 2,135


Return to How do I....?

Who is online

Users browsing this forum: Artpunk, Kagubro, Mirlas and 27 guests