Making sound and music import easier?

Get help using Construct 2

Post » Thu Apr 12, 2012 9:07 am

Hi everyone,

I'm using windows vista, and it seems like 90 percent of the time I try to impoirt .WAV files to my construct2 projects I get error messages or warnings that I need windows 7 to convert the wav!

Is there some easy way I can pre-convert the .WAV files to a .WAV format that construct will be OK with on Vista?

anyone have a solution for this issue?

thanks.
B
46
S
8
G
4
Posts: 414
Reputation: 6,830

Post » Thu Apr 12, 2012 9:54 am

Does it really have to be wav?

I'd say download Audacity and export the files as ogg files instead.
B
73
S
20
G
10
Posts: 524
Reputation: 9,896

Post » Thu Apr 12, 2012 10:11 am

OK. I just read the sound doccumentation better and see that its a matter of the automatic conversion to .m4a that only works automatically on windows 7.

I see that I need to convert them myself as a vista user, BUT once converted, do I just import them as I would a .wav? is so, will this create the ogg for me as well? its unclear about what we non windows 7 users do after making these converisons ourselves.
B
46
S
8
G
4
Posts: 414
Reputation: 6,830

Post » Thu Apr 12, 2012 10:23 am

thanks inkbot, BUT it says the ogg wont be automatically converted to create the alternate m4a version for browsers that dont play ogg. :(

I'll try finding something that can batch convert WAV files to PCM wave files, then hopefully vista can handle the conversion...

otherwise I guess I need to manually convert them to m4a and then import the m4a files as well as the wav files to insure that the alternate format is used in the other browsers. :(

This is the part I'm unclear about still.
B
46
S
8
G
4
Posts: 414
Reputation: 6,830

Post » Thu Apr 12, 2012 11:37 am

I know this is a simple thing and I should be patient... but I just converted the files to m4a myself, imported them at the same time as the .wav files and instead of importing them as ogg and mfa versions of the same sound, it RENAMED them in an attempt to avoid conflict! Now I've got a big mess and.

Please let us vista users know how to sucessfully install the sound files we have converted properly.

Wouldn't it make sense to NOT rename peoples files on them if they are trying to import sounds of m4a format which have the same name as already installed WAV and ogg files?
B
46
S
8
G
4
Posts: 414
Reputation: 6,830

Post » Thu Apr 12, 2012 11:57 am

OK. got it.

Convert the wave files to both ogg and m4a files (with the same name otherwise of course) and Import them (AND NOT THE WAV VERSION) at the same time. Then when you play a sound or song by name, just put the name without the extension at the end (like .ogg or .m4a)

I think I'm all set now.
B
46
S
8
G
4
Posts: 414
Reputation: 6,830

Post » Thu Apr 12, 2012 1:49 pm

I'm still having issues in fact...even though I have now sucessfully imported m4a equivelents of all the sound effects, stii nothing is played in most browsers! Is it because I imported the m4a's at a later time, AFTER making the events that trigger these sounds.

Does Construct not look for m4a's IF there were none at the moment you made the event to trigger the sound?
B
46
S
8
G
4
Posts: 414
Reputation: 6,830

Post » Thu Apr 12, 2012 2:30 pm

YUP!

I renamed all my sounds in a folder (not in construct). I had an ogg anf m4a version of each, same exact names, ready to go. I imported them all at once..
THEN, I edited my events that triggered sounds to reference the NEW named versions of my sounds that I had just imported (in both m4a and ogg at the same time), and now it works.

I hope this helps future non windows 7 users, because this was annoying.
B
46
S
8
G
4
Posts: 414
Reputation: 6,830


Return to How do I....?

Who is online

Users browsing this forum: selaus and 0 guests