Mario battle clone problem

Get help using Construct 2

Post » Mon Aug 11, 2014 3:48 pm

Hey guys
i am trying to replicate the mario battle system and i am having problems with the collisions betwen the two players :-(

The vector x and y work fine when they overlap each other on the left side of the screen, but when they are on the right side of the screen , the player on the left takes over and the player on the right side can't push him the same way as he can on the left side of the screen :-)

Can someone please help me with this? i really dont see what i am doing wrong.

here is the capx
https://dl.dropboxusercontent.com/u/1678586/battle.capx
Last edited by Escualo on Tue Aug 12, 2014 9:13 am, edited 1 time in total.
B
4
S
1
Posts: 23
Reputation: 951

Post » Mon Aug 11, 2014 4:14 pm

Looks familiar :). Are you sure you shared the right CAPX. I cannot find where you put this.
B
34
S
9
G
3
Posts: 517
Reputation: 5,226

Post » Mon Aug 11, 2014 8:43 pm

@katala thanks for the reply :)
i will upload a new one first thing tomorrow.
B
4
S
1
Posts: 23
Reputation: 951

Post » Tue Aug 12, 2014 9:14 am

@katala Hey i have uploaded the right capx :-) and fixed the link avobe.
B
4
S
1
Posts: 23
Reputation: 951

Post » Tue Aug 12, 2014 10:51 am

This is the problem Player2.X+1520
The forces get messed up on right side when the x.position gets higher.

I think it works quite well even when you keep it just 1520 and -1520 or you could use VectorX+1520 etc..
B
34
S
9
G
3
Posts: 517
Reputation: 5,226

Post » Tue Aug 12, 2014 11:30 am

Thanks for your help @Katala :D
i will try that.
B
4
S
1
Posts: 23
Reputation: 951

Post » Tue Aug 12, 2014 11:49 am

Thanks @katala i works perfectly :-D
B
4
S
1
Posts: 23
Reputation: 951


Return to How do I....?

Who is online

Users browsing this forum: RalleRoyal, totoe and 25 guests