Master mute doesn't work properly

For questions about using Classic.

Post » Wed May 16, 2012 10:50 pm

Hello guys! I'm using Xaudio2 plugin in my game. In options menu I've created buttons to mute/unmute sound in a game. I've used set Master muted/unmuted action. But when I'm pressing buttons nothing happens.

What am I doing wrong?
B
62
S
14
G
5
Posts: 265
Reputation: 5,978

Post » Thu May 17, 2012 3:37 am

[QUOTE=Wolod]What am I doing wrong?[/QUOTE] You are playing music. Really, I'm not joking. The XAudio2 implementation differentiates between music and sound. The master volume options belong to the sound part. Music has its own seperate volume options, that you would need to set to 0 (zero) to mute.
Image
B
24
S
8
G
10
Posts: 1,821
Reputation: 8,279

Post » Thu May 17, 2012 8:17 am

Thanks tulamide! You've helped me a lot. I can't believe that I hadn't thought about that kind of solution myself.
B
62
S
14
G
5
Posts: 265
Reputation: 5,978


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests