Memory issue

For questions about using Classic.

Post » Sat Dec 15, 2007 2:03 pm

Editor seems to keep increasing memory used even when nothing is added. Just moving the mouse over objects I can see ram usage increasing and never being released.
B
1
G
5
Posts: 7
Reputation: 1,239

Post » Sat Dec 15, 2007 2:19 pm

Memory usage stays constant here, just the CPU increases as I move the mouse around. The task manager's figures for memory are pretty approximate, it could be normal behaviour, unless the memory leak is significant (ie. you can add 100mb to the memory usage just by waving the mouse). How much does memory increase by, which objects did you try it with (I used sprites and tiled backgrounds), and does closing the layout free the memory?
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578

Post » Sat Dec 15, 2007 2:45 pm

open layout and task man shows 24000 k
A few minutes just moving mouse and clicking up to 180000 k. Over 1000 k selecting or moving mouse over.
I was using it eariler and was over gb ram without doing much.
I just have sprites I was testing effects with.
Closing layout doen not decrease. Only closing app does.

I open a couple of other construct apps and did not see the same behavior. Just small increase and frees up when closing.
B
1
G
5
Posts: 7
Reputation: 1,239

Post » Sat Dec 15, 2007 7:23 pm

and memory was stable. I guess it has to do with effects.
B
1
G
5
Posts: 7
Reputation: 1,239


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 5 guests