Mobile: Touch failing over 50% CPU usage.

Discussion and feedback on Construct 2

Post » Wed Jul 06, 2016 5:34 pm

@Mirlas i tried your test also but the blue dot never miss. Always moved to where i touched. I can't replicare it.
Follow my progress on Twitter
or in this thread Archer Devlog
B
41
S
18
G
19
Posts: 1,045
Reputation: 13,977

Post » Wed Jul 06, 2016 6:04 pm

I tried the test on a HTC with Android 5 right now, it seems that never fails.
Problem of Android 6?
Problem with my phone?

Anyone with galaxy 6S and android 6 can try?

Edit:
Possibly if you have enabled certain options of "Developer options" in Android, that could cause failures.
B
30
S
13
G
21
Posts: 838
Reputation: 14,656

Post » Wed Jul 13, 2016 4:26 pm

Hey how are you building your game for Windows @tunepunk? Are you using Visual Studio or Intel XDK?

I started testing in Windows Phone today and surprise! I'm having problems with touch like you are. Not exactly like you describe but still, touch craps out. I tried building with VS and XDK and my game breaks with both methods :roll:
B
74
S
52
G
62
Posts: 406
Reputation: 39,075

Post » Wed Jul 13, 2016 4:39 pm

Artpunk wrote:Hey how are you building your game for Windows @tunepunk? Are you using Visual Studio or Intel XDK?

I started testing in Windows Phone today and surprise! I'm having problems with touch like you are. Not exactly like you describe but still, touch craps out. I tried building with VS and XDK and my game breaks with both methods :roll:


Android has an option called "Developer options."
In one of these options you can make a chart that appears on the screen when android it detects a touch.
You can check if windows phone has a similar option.

In my case, sometimes (I do not know the reason), with this test, android does not detect the touch and the graph not appear.

However, when I write a message and repeatedly striking the screen, never fails and always the graph is displayed.
B
30
S
13
G
21
Posts: 838
Reputation: 14,656

Post » Wed Jul 13, 2016 5:59 pm

@Artpunk yea, it seems to be a windows phone issue. It happens when I preview in edge, and after building with both XDK and Visual studio. Even XDK's own demos in app preview has this issue, so I hope more people report it to microsoft.
Follow my progress on Twitter
or in this thread Archer Devlog
B
41
S
18
G
19
Posts: 1,045
Reputation: 13,977

Post » Thu Jul 14, 2016 5:40 am

Ok. Yes I am getting the same thing. And your observation that locking / unlocking the screen forces touch to start working is the same for me too.

Overall though, I get much better performance building a Windows UAP with XDK than with Visual Studio.
With XDK I get better fps, less problems with music and fixes problem of my game not being centered.
My game just seems to be broken in every direction with Visual Studio.

Ok Ill go report this bug with Microsoft as well. Where did you submit a report tunepunk? The Microsoft Dev website? (https://developer.microsoft.com)
B
74
S
52
G
62
Posts: 406
Reputation: 39,075

Post » Thu Jul 14, 2016 7:01 am

i've noticed on changewindows.org that they did some neat updates to windows mobile, which should be released now with windows 10 anniversary on 2nd august.

there was a lot of battery drain and what not..
Sea Monsters template - Isometric
Also includes 40 pages PDF of optimizations and "how-to" for your games, and how the "sea monsters" template was built. Follow link for details :)

sea-monsters-templates-and-assets_t162705
B
43
S
14
G
12
Posts: 626
Reputation: 9,450

Post » Thu Jul 14, 2016 7:48 am

@Artpunk i don't remember exactly what page, it wasn't the regular dev pages, it was on some special page regarding windows phone. Any bug report is good though, so if you find another place to report it should be good too.

@sayadijin Yeah hopefully it will be fixed soon. I guess quite a lot of apps are affected by this issue.
Follow my progress on Twitter
or in this thread Archer Devlog
B
41
S
18
G
19
Posts: 1,045
Reputation: 13,977

Post » Thu Jul 21, 2016 8:53 pm

UPDATE: Bug has been confirmed by Microsoft and has been assigned to someone to look at it. If anyone else want to follow or report to the same issue you can do it here.

https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/8075745/
Follow my progress on Twitter
or in this thread Archer Devlog
B
41
S
18
G
19
Posts: 1,045
Reputation: 13,977

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: Palnix777 and 15 guests