Mouse over problem

Get help using Construct 2

Post » Fri Sep 07, 2012 12:34 pm

Well, ive this game. When i male the mouse go over the sprite (An icon)
When i put the mouse over the icon, the animation plays well, when i moving the mouse elsewhere, the animation kept playin, how do i stop that?
B
10
S
3
G
6
Posts: 33
Reputation: 4,285

Post » Sat Sep 08, 2012 2:54 am

Hey,

If you invert the action that tells the animation to play (so it reads as - mouse is not over sprite) then give it an action like set frame to X or stop animation that should work.
ImageImage
B
74
S
17
G
6
Posts: 1,039
Reputation: 10,605

Post » Sat Sep 08, 2012 4:00 am

> Mouse > Mouse over object, play animation
> System > Else, stop animation
B
13
S
5
G
3
Posts: 63
Reputation: 3,989

Post » Wed Nov 28, 2012 10:48 pm

I've got a similar issue, but only when using multiple areas that I want to hover over and start animations, or in my case set frames of sprites when I'm mousing over.

For example, I've got 5 different sprites, each of them has two frames, and whenever I drag the mouse over each one, I want them to switch to frame 2. I've set it up a few different ways, without any luck.

As of right now, I've got it set up like this

Mouse > on cursor is over sprite1 > sprite1 > set animation frame 1

system > Else > sprite1 > Set animation to frame 0

If I try to add any more sprites into the mix, the first only the last sprite will switch frames, for example:

Mouse > on cursor is over sprite1 > sprite1 > set animation frame 1
Mouse > on cursor is over sprite2 > sprite2 > set animation frame 1
Mouse > on cursor is over sprite3 > sprite3 > set animation frame 1

system > Else > sprite1 > Set animation to frame 0
               sprite2 > Set animation to frame 0
               sprite3 > Set animation to frame 0

Any help would be appreciated!
B
2
Posts: 1
Reputation: 302


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 32 guests