Moved cell/sec too high with TiledBackgorund

Bugs will be moved here once resolved.

Post » Tue Jan 21, 2014 8:43 am

Link to .capx file:
https://drive.google.com/file/d/0BxoHB3AGjIpYMmpGN09XdlJGQnc/edit?usp=sharing

Steps to reproduce:
1. Add a lot of Tiledbackground with physics behavior.
2. Set Immovable to Yes.
3. Check Tiledbackground collision in event.
4. Run Debug Layout.

Observed result:
We can see "Moved cell/sec" very high (Moved cell/sec = 480) because there aren't moving objects, but with sprite no problems (Moved cell/sec = 0).

Expected result:
I expect the same result of sprite, (moved cell lowest).

Browsers affected:
All browser.

Operating system & service pack:
Windows 8 x64.

Construct 2 version:
    From r155 to r158.2.

Sorry for English.Francy112014-01-21 08:54:35
B
5
Posts: 17
Reputation: 337

Post » Tue Jan 21, 2014 8:51 am

It would be nice to turn off permission in Google driveJoannesalfa2014-01-21 08:51:35
B
99
S
35
G
29
Posts: 3,139
Reputation: 28,421

Post » Tue Jan 21, 2014 8:55 am

Ops sorry. Try now :).
B
5
Posts: 17
Reputation: 337

Post » Tue Jan 21, 2014 10:15 am

I'm not sure what you're looking to accomplish, you know tiled objects don't use collison polygon.

B
99
S
35
G
29
Posts: 3,139
Reputation: 28,421

Post » Tue Jan 21, 2014 10:52 am

Yes, I know. I think that also with Immovable TiledBackground, moved cell should be 0 because no object are moving in the layout.
B
5
Posts: 17
Reputation: 337

Post » Fri Jan 24, 2014 5:32 pm

Closing as won't fix. This really does not matter significantly; moving cell is really cheap and quick and it's only 8/tick. It happens to objects along cell borders due to the origin being off-center so the Physics behavior seems to want to update the bounding box every tick. But this is pretty much inconsequential.
Scirra Founder
B
403
S
238
G
89
Posts: 24,653
Reputation: 196,143


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests