Movement behaviours and collisions

Bugs will be moved here once resolved.

Post » Mon Jul 16, 2012 11:13 am

Objects with default behaviours do not interact correctly with other objects using polygon collision mode unless they have had a polygon collision setting changed themselves(guess poly collision/set bounding box)

Example -
Platform behaviour - https://dl.dropbox.com/u/1487524/Scirra/C2/platformBehaviour.capx
Steven2012-07-18 05:18:44
B
9
S
2
G
4
Posts: 346
Reputation: 2,726

Post » Wed Jul 18, 2012 5:24 am

I discussed with Steven on IRC about this issue.

His textures were drawn in C2's image editor.

When you preview the project in either chrome or FF, the collisions polygons seem off.

To fix it, go edit the "Player" sprite and either "set to bounding box" or "guess polygon shape".
Then the collision polygon of the Sprite2 seems to be finaly "processed" (before it looked like bounding box).

Could it be a bug somewhere ?
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Sun Jul 22, 2012 1:13 am

finally, this is what fixed it for me, this was driving me crazy, I was just about to report that polygon collision doesn't work for me at all. This is definitely a bug
B
15
S
2
G
3
Posts: 50
Reputation: 1,863

Post » Mon Jul 30, 2012 6:17 pm

Somehow your player object got a collision mask several times larger than the object, even though it ought to be bound to the object size. This caused the weird collision result. Can you remember anything you were doing editing the player object beforehand that may have caused it?

Anyway I've added a fix for r100, so hopefully this will be fixed and won't happen again.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests