Multiple controllers mis-recognition

Bugs will be moved here once resolved.

Post » Tue Oct 31, 2017 5:26 pm

Problem Description
In Windows 10 machines (apparently, only if on the recently released versions), when plugging 1 controller, 2 controllers are recognised, with one of these two first indexes (0 or 1) being unusable for the rest of the experience. If other controllers are connected after they are recognised correctly.

Attach a Capx
https://www.dropbox.com/s/zlnzxmag6jyh50x/Controller%20Test.capx?dl=0

Description of Capx
Display the number of connected controllers recognised by the program (Gamepad Count) within a text object.

Steps to Reproduce Bug
  • Open the capx with no controllers plugged in.
  • Go to the browser of choice.
  • Test the project, 0 controllers will be displayed.
  • Plug in 1 controller.

Observed Result
[*] Test the project in Chrome with no controllers plugged in, 0 controllers will be displayed.
[*] Plug in 1 controller: 2 is displayed if on the latest version of Windows.
[*] Repeat the same process until the 4th step, but on Windows without Falls Update.
[*] Only 1 controller is recognised.[/list]

Expected Result
When only 1 controller is plugged, only 1 is displayed in the Gamepad count.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
Correct Behavior: Windows 10 Pro x64 1703
Incorrect Behavior: Windows 10 Home x64 1709

Construct 2 Version ID
Construct2 r247
B
38
S
11
G
4
Posts: 33
Reputation: 5,285

Post » Tue Nov 14, 2017 5:07 pm

The recognition of gamepads is implemented entirely by the OS and browser. You should probably report this to Google since I doubt there is anything we can do about it. It sounds like an issue in Windows itself, if it only happens in the Fall Creator's update.
Scirra Founder
B
402
S
238
G
89
Posts: 24,644
Reputation: 196,095

Post » Wed Nov 15, 2017 12:29 am

Ashley wrote:The recognition of gamepads is implemented entirely by the OS and browser. You should probably report this to Google since I doubt there is anything we can do about it. It sounds like an issue in Windows itself, if it only happens in the Fall Creator's update.

Oh I will for sure! I just wanted to make sure I wasn't alone in noticing this issue, since I've already tried in two updated computers vs two non-updated ones and my results were pretty much confirmed, but I wasn't sure.

In any case, https://steamcommunity.com/app/353370/discussions/1/1489987634018835888/ makes me think it might be a global issue within W10, as you suggested.

Thanks!
B
38
S
11
G
4
Posts: 33
Reputation: 5,285

Post » Wed Nov 15, 2017 12:29 pm

Closing as it looks like this is an issue in the latest Windows 10 update.
Scirra Founder
B
402
S
238
G
89
Posts: 24,644
Reputation: 196,095


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest