Multiple sound source

Get help using Construct 2

Post » Sun Mar 09, 2014 9:54 am

Message: Ubru can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
Hello, my problem is with multiple sound source (depending on position of character).
I want to make multiple objects which every one of them produce own sound with volume relative to position of player and I want more instances of these objects. When I rise number of instances sound is somehow stopped or bugger.

I tested it in Chrome and Firefox. In chrome there is little sound on start and in firefox you can hear that "buggy" sound all time. Something like that sound channel is overloaded. I do not know why? Where is that problem or how can I solve this thing? I think this is normal situation in game when you have got some level and you want many object with some sound run at same time.

There is a link of .CAPX
https://www.dropbox.com/s/og5n8bcvo3jqa ... oblem.capx

Thank you very much for any help or suggestion! Please I need to solve it.
B
11
S
3
Posts: 37
Reputation: 999

Post » Sun Mar 09, 2014 1:12 pm

Your problem is that you are calling the sound loops every tick. Try this instead.

And just to test it you might want to reduce the number of "sound makers" to one of each and stick them one in each of the four corners.
You do not have the required permissions to view the files attached to this post.
August 2015 - I misplaced a lot of links - I will try to find backups and repost. If You find a post that interests please reply to post with @rampackwobble and I will get a nudge!

If you find my posts useful please consider donating something to a local charity or to the http://www.mndassociation.org/
B
64
S
34
G
47
Posts: 1,194
Reputation: 30,892

Post » Sun Mar 09, 2014 3:05 pm

It works thank you very much. Finally right solution really thank you.
B
11
S
3
Posts: 37
Reputation: 999


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 6 guests