Music is loading too long

Discussion and feedback on Construct 2

Post » Thu Feb 14, 2013 11:31 am

I set on start of layout play music and after game start music is loading 5-10 sec brfore starts play.

How to fix this?
B
94
S
19
G
34
Posts: 1,840
Reputation: 27,988

Post » Thu Feb 14, 2013 12:51 pm

Preload it using the audio preload action.
B
90
S
30
G
24
Posts: 3,189
Reputation: 32,400

Post » Thu Feb 14, 2013 2:25 pm

Increase your server bandwidth :) If it's in the music folder, it should be streamed so it ought to play as soon as it's got enough data to start playing - it won't need to download the entire track. So it must be a pretty slow server that it takes 5-10 sec to do that.Ashley2013-02-14 14:25:50
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Thu Feb 14, 2013 3:58 pm

while we are on the topic...
@Ashley i probably asked for this before but can you add a "preload everything!!!" event for the audio object?

i prefer to have everything cached instead of the download on first use stuff...
B
33
S
6
G
7
Posts: 338
Reputation: 7,424

Post » Thu Feb 14, 2013 4:30 pm

I second that, preload everything would be really useful in some cases where the gameplay depends on the sounds playing.
B
38
S
8
G
3
Posts: 438
Reputation: 6,869

Post » Thu Feb 14, 2013 8:40 pm

+1 for preload all Sounds action
B
20
S
5
G
8
Posts: 325
Reputation: 6,473

Post » Fri Feb 15, 2013 5:31 pm

@Ashley can you add a new option in importing wav files? i mean encoding quality- add 64 kb/s and 80 kb/s ?
i try display music with this quality and sounds good for me even if have 64 kb
B
94
S
19
G
34
Posts: 1,840
Reputation: 27,988

Post » Fri Feb 15, 2013 8:45 pm

+1 for Music Families :)
B
35
S
16
G
16
Posts: 2,222
Reputation: 16,589


Return to Construct 2 General

Who is online

Users browsing this forum: Artpunk and 11 guests