Music Volume Control not Working Correctly

Bugs will be moved here once resolved.

Post » Thu Nov 19, 2015 4:10 am

Problem Description
Volume Control for music only works with music inside the sounds folder on iOS Safari. On iOS Chrome, there is no sound at all.

Attach a Capx
https://www.dropbox.com/s/m8cm1lw6lvvrw ... .capx?dl=0

Description of Capx
Shows the music working inside the sounds folder.

Steps to Reproduce Bug

  • Move music (themeIntro), into music folder.
  • Test on iOS Safari.
  • Click settings button in upper right corner, then the music button.

Observed Result
if the steps above are reproduced (music is inside music folder) the volume control will not work.

Expected Result
Volume control for music, should work with the music inside the music folder.

Affected Browsers
  • iOS Chrome: No sound at all
  • iOS Safari: YES

Operating System and Service Pack
Win 10

Construct 2 Version ID
r216
B
27
S
14
G
8
Posts: 112
Reputation: 7,266

Post » Mon Nov 23, 2015 7:30 pm

same problem under Android devices
B
31
S
11
G
6
Posts: 1,582
Reputation: 8,362

Post » Tue Nov 24, 2015 4:45 pm

This is a bug in iOS. I've reported it here: https://bugs.webkit.org/show_bug.cgi?id=151589

You might be able to work around this using mute/unmute, it looks like your demo is trying to use very low volumes to simulate muting.

@imothep85 - I cannot reproduce this problem on Android, only iOS. Please file a separate report following all the guidelines if you think there is a problem there.
Scirra Founder
B
373
S
218
G
83
Posts: 23,433
Reputation: 185,806


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests