Music volume gets extremely low when a sound is played.

Discussion and feedback on Construct 2

Post » Wed May 20, 2015 8:10 am

I can't seem to find any information about this, and I'm positive that I can't be the only one experiencing this. The music just gets very quiet when a sound is played for whatever reason. The music should just play in the background at a locked volume and not be dynamically adjusted. I have tried a lot of things, and I am out of ideas. Is there a way to do that? Cause I'm stumped. Thank you!
B
8
Posts: 28
Reputation: 756

Post » Thu May 21, 2015 7:32 pm

Does anyone have this problem or similar?

Using the On start of layout, play music works fine, until a sound is played at which point the music volume gets so low, is there a fix for this? I may just be overlooking something with Audio. Any help is greatly appreciated, thank you.
B
8
Posts: 28
Reputation: 756

Post » Fri May 22, 2015 1:21 am

You'll need to provide more information. What browsers are you testing on? Mobile or desktop?

Put together a minimal capx and other people will be able to see if it's an actual bug or just a problem on your end.
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Fri May 22, 2015 10:12 am

Hey, thank you for the reply!

It seems to be a problem related to Chrome, as testing in IE has revealed the problem only exists in Chrome.

https://www.dropbox.com/s/t8btg6l6jmt8kgh/MusicVolumeProblem.capx?dl=0

Just press the Sound button, and the music volume will get very low. Appreciate your time, thank you.
B
8
Posts: 28
Reputation: 756

Post » Fri May 22, 2015 11:48 am

@Wolph , your example plays just fine, no volume drops what so ever... I tried on Firefox, IE 11 and Chrome - NW.js and got the same results.

So, I can only think of two explanations for what you describe.

1) There is something wrong with your PC.

2) You are experiencing a psychoacoustic phenomenon. Due to the nature of the "ouch" sound (very loud, sharp and short without any tail) the brain "lowers" the volume perception sensitivity, in order to protect us. Since the sound is so short, there isn't enough time for the brain to compensate this initial sensitivity drop, and we experience the background music as being lowered in volume.

Try this: play the "ouch" sound at -60 db. I bet you wont hear any difference on the music's volume. Or try another sound, a more subtle one that has a bit of a falloff, a reverb or something... It will blend much better on top of the music.
composer - multimedia artist
www.eli0s.com/en/
B
69
S
26
G
5
Posts: 1,146
Reputation: 9,829

Post » Fri May 22, 2015 12:10 pm

@Eli0s Love reason number 2, but unfortunately I am not experiencing that phenomenon.

I have narrowed it down to my hardware/Chrome, I tested on my other computer in Chrome, and it works fine. So perhaps something is dynamically adjusting the volume from Chrome or my audio settings. Anyway, thank you for the response guys! I think I can debug it from here.
B
8
Posts: 28
Reputation: 756

Post » Fri May 22, 2015 12:14 pm

Okay it was my Audio Settings, Playback Devices > Speakers > Properties > Enhancements, Uncheck Loudness Equalization. That fixes it, strangely it only equalized the music in Chrome... Anyways thank you again!
B
8
Posts: 28
Reputation: 756

Post » Fri May 22, 2015 12:30 pm

@Wolph , lol , so I guess your audio settings highjacked the brain's responsibility for balancing loud noises! :b

It is indeed strange that it was only affecting Chrome...
composer - multimedia artist
www.eli0s.com/en/
B
69
S
26
G
5
Posts: 1,146
Reputation: 9,829


Return to Construct 2 General

Who is online

Users browsing this forum: Sockratease and 7 guests