must i always get latest C++?

For questions about using Classic.

Post » Sun Nov 30, 2008 5:59 am

must i always reinstall the C++ and directX components each and every time i update to the latest version of construct? if it prompts me im assuming yes, but im just curious. i know with 97.7 i had to get the latest version of directX, but once again, im curious :)
B
25
S
3
G
6
Posts: 1,197
Reputation: 5,620

Post » Sun Nov 30, 2008 6:14 am

LOL awesome question. That prompt drives me nuts!
B
13
S
3
G
5
Posts: 286
Reputation: 3,193

Post » Sun Nov 30, 2008 6:28 am

I always say no to them unless I need the latest DirectX runtime, and I haven't had any problems. I think only the DirectX one needs to be updated, but only if the version Construct uses is updated.
Moderator
B
98
S
36
G
19
Posts: 1,584
Reputation: 17,717

Post » Sun Nov 30, 2008 10:37 am

Once I install Construct with there "C++ and DirectX", there no further need to install them with updates. Don't worry, even if they are needed, they are always available in Construct directory:
[list:w0wxmdfz]
[*:w0wxmdfz]vcredist_x86.exe[/*:m:w0wxmdfz]
[*:w0wxmdfz]dxwebsetup.exe[/*:m:w0wxmdfz][/list:u:w0wxmdfz]
B
6
S
3
G
6
Posts: 219
Reputation: 3,013

Post » Sun Nov 30, 2008 10:42 am

Generally speaking, no, and in future we'll update the installer to remove the prompts if you don't need to.

However in a recent build we've upgraded the Direct-X version needed, to be safe you should update it sometimes (though this is a rare occurance). The C++ distribution has never changed.
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests