My game lags in Landscape?

Discussion and feedback on Construct 2

Post » Tue Oct 09, 2012 12:07 pm

If I run my game on my iPad 3 in portrait it is beautiful and smooth, however if I run it Landscape it has a very low fps.

Any ideas?
B
7
S
2
Posts: 75
Reputation: 1,100

Post » Tue Oct 09, 2012 3:40 pm

Can you share a .capx?

Have you tried disabling retina mode?Ashley2012-10-09 15:40:12
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,518

Post » Tue Oct 09, 2012 5:07 pm

This is the same issue that I mentioned here: http://www.scirra.com/forum/major-ipad-performance-problem-using-landscape_topic56928.html

Here's the .capx I used: http://www.amirai.net/ipad/sprites/ipadfps.zip

The exported HTML: http://www.amirai.net/ipad/sprites/

In that thread I mention one of the space blaster demos has that problem as well, but it's only the old space blaster demo, not the new one with sound: http://www.scirra.com/labs/sbperf/

In my tests, I found that the problem only happens with some display modes, in particular it happens with full screen crop and doesn't happen with full screen letterbox.

The problem does happen with retina mode.

I mentioned in that thread about the space blaster performance test's text not updating itself properly - I didn't realize that that was because clear background was set to off.Arima2012-10-09 17:09:55
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Tue Oct 09, 2012 11:51 pm

So how did you end up fixing the problem? If you did.
B
7
S
2
Posts: 75
Reputation: 1,100

Post » Wed Oct 10, 2012 12:29 am

I didn't.
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Wed Oct 10, 2012 12:37 am

I checked and the problem doesn't happen with retina mode disabled, but it's not an issue of the ipad just not being able to handle it because it handles fullscreen retina mode just fine with letterbox mode selected instead.
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Wed Oct 10, 2012 12:50 am

Are you sure this still happens in the latest beta release with iOS 6?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,518

Post » Wed Oct 10, 2012 1:05 am

Yup. Just checked it, happens on preview over LAN and after export on an ipad 3 with iOS 6.

http://www.amirai.net/ipad/105/Arima2012-10-10 01:06:30
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Wed Oct 10, 2012 7:24 pm

@Ashley

Found some new info. I modified the test before, and discovered that the problem happens in fullscreen letterbox landscape mode as well in some scenarios.

http://www.amirai.net/ipad/r105/ipadfps.zip

This is the sprite test in full screen letterbox mode with a canvas size of 2048x1345. Works smooth: http://www.amirai.net/ipad/r105/

Lower the vertical resolution in the properties by 1 pixel to 2048x1344, and the bug happens: http://www.amirai.net/ipad/r105/2/

Also, if I load those links above to the exported versions, I noticed if I rotate the device before the page has finished loading and the blue bar under the web address disappears, it doesn't resize/adjust the canvas to fit the window. It only readjusts it properly if the device is rotated after it's finished.
Moderator
B
87
S
32
G
33
Posts: 3,005
Reputation: 27,397

Post » Fri Oct 12, 2012 4:19 pm

@Arima : iPad has a 2048x1536 resolution in landscape mode.
The status bar at the top is 40 pixels high, and the URL bar is 152 pixels high. When you remove those, you have 2048x1344, the exact resolution you have a problem with. That must be something related to it.

Can you try to start in landscape mode, and go the portrait mode set at (1536)x(2048-152-40) (i.e. 1536x1856), and then 1536x1855, to check if you have that bug ?
B
33
S
9
G
6
Posts: 709
Reputation: 6,704

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests