My platfomrer "skates?"

Get help using Construct 2

Post » Mon Feb 20, 2012 6:42 pm

Hello, I'm new here and new to Construct. For the last few days,
I've been fiddling with it, trying to make the basics for a
platformer, but I've ran into an unusual problem that I can't
seem to fix. I'm thinking that the answer is simple, but it
eludes me.

My little man can run and jump with proper animations, but if you
hold a run key while landing, he appears to "skate" across surfaces
until touching a barrier. Could someone please point out what I'm
missing so that I can continue? Thanks a ton!

>>My Test File<<
B
5
Posts: 3
Reputation: 631

Post » Mon Feb 20, 2012 7:28 pm

The problem is, to put it simply, your animation system was way too complicated. I reworked it for you to only use a few events. It's much easier to follow now and (unless I'm missing something) works exactly the same in the end. Lemme know if you have any questions about it!

http://db.tt/0XpYgDky

The sound might not work the way you want it to, so feel free to change all that. I didn't pay much attention to the sound.
B
20
S
9
G
6
Posts: 607
Reputation: 6,112

Post » Mon Feb 20, 2012 7:44 pm

Thanks a ton Sully, this is much better! Like I said, I'm quite new at
this, so I figured I'd over-complicated things. I'll try using this, and
try to keep my events a little more streamlined from now on.


thanks again!
B
5
Posts: 3
Reputation: 631

Post » Mon Feb 20, 2012 7:55 pm

No problem. Welcome to Construct 2 by the way!
B
20
S
9
G
6
Posts: 607
Reputation: 6,112


Return to How do I....?

Who is online

Users browsing this forum: Draconinho, LeFuji, totoe and 10 guests