My player won't stop moving

Bugs will be moved here once resolved.

Post » Thu Jan 05, 2017 3:24 am

I'm making a platform game (trying at least) and earlier for no reason I can think of, when I try and move the player by clicking the arrow keys (arrow is down event) he'll just keep walking the direction I pressed until he walks off the layout , dies, or I press the up arrow and he tries to jump.

Is there any reason he might be doing this, and how can I fix it? Any help would be greatly appreciated.
B
3
Posts: 2
Reputation: 179

Post » Thu Jan 05, 2017 3:31 am

Are you using the platform behaviour? And if so, are you using default controls or simulated ones?
B
5
S
1
Posts: 6
Reputation: 337

Post » Thu Jan 05, 2017 3:44 am

scarybarry wrote:I'm making a platform game (trying at least) and earlier for no reason I can think of, when I try and move the player by clicking the arrow keys (arrow is down event) he'll just keep walking the direction I pressed until he walks off the layout , dies, or I press the up arrow and he tries to jump.


Are you previewing with the Edge browser? If you are, try it in other browsers. Edge has been giving me the same trouble, ever since a particular Windows 10 update somewhere along the way (not sure which one, but someone mentioned the "anniversary update.") It seems to be an Edge issue, in other words. People have been complaining to Microsoft about it, but I'm not sure if anyone has come up with a solution. For now I'm just waiting to see what happens and concentrating on using the other browsers. Sorry I can't be more helpful to you.
B
11
S
2
Posts: 24
Reputation: 686

Post » Thu Jan 05, 2017 4:03 am

If you post a capx or even an image of your event sheet it will make it much easier for us to figure out what's going on. Also, in the future, please post stuff like this in the "How do I" section of the forum as this is not a Construct 2 bug.
B
60
S
20
G
56
Posts: 1,077
Reputation: 35,941

Post » Thu Jan 05, 2017 4:11 am

It may be a bug if it's anything like terransage said, relating to the edge browser. But yeah, I getchu.
B
5
S
1
Posts: 6
Reputation: 337

Post » Thu Jan 05, 2017 9:27 am

scarybarry wrote:I'm making a platform game (trying at least) and earlier for no reason I can think of, when I try and move the player by clicking the arrow keys (arrow is down event) he'll just keep walking the direction I pressed until he walks off the layout , dies, or I press the up arrow and he tries to jump.

Is there any reason he might be doing this, and how can I fix it? Any help would be greatly appreciated.


This section of the forum is specifically for bugs in the Construct 2 software.

If you think you have found a bug, you must follow the Bug Report Guidelines in order for your report to be investigated, otherwise it will be closed.

As it stands, your report is practically useless. Please update your first post with at least a minimal .capx and precise steps to reproduce the error.

Thanks
If your vision so exceeds your ability, then look to something closer.
Moderator
B
131
S
29
G
81
Posts: 5,328
Reputation: 56,630

Post » Thu Jan 05, 2017 6:10 pm

Well, if i am allowed to give my opinion on this. This problem is several times reported.
It is simple, when pressing two keys together, the platform behaviour goes nuts in edge.
Every and each platform template shows the problem.
Since it is like a day work to fill in a bug report exactly as requested, that is a bit outrageous for such a simple to describe problem.

Forgive me my insubordination.
B
33
S
18
G
27
Posts: 2,435
Reputation: 20,334

Post » Thu Jan 05, 2017 8:01 pm

Are you previewing with the Edge browser? If you are, try it in other browsers. Edge has been giving me the same trouble, ever since a particular Windows 10 update somewhere along the way (not sure which one, but someone mentioned the "anniversary update.") It seems to be an Edge issue, in other words. People have been complaining to Microsoft about it, but I'm not sure if anyone has come up with a solution. For now I'm just waiting to see what happens and concentrating on using the other browsers. Sorry I can't be more helpful to you.


Tarensage, Edge was the problem, thanks!
B
3
Posts: 2
Reputation: 179

Post » Thu Jan 19, 2017 5:13 pm

Closing, see the bug report requirements.
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,228


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests