My TIGSource competition entry: This Cursed Rock

Post your Construct-made creations!

Post » Mon Dec 01, 2008 1:20 am

Deadeye, can you send him a version of the game with the XAudio2 object deleted from all layouts and see if that works?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,630

Post » Mon Dec 01, 2008 1:24 am

Hey, welcome :)

I hope these guys can help you out. I wouldn't have the first clue as to what's going on.

Also, I didn't even know there were three Construct entries until you mentioned it. I haven't been able to keep up with the compo because I was so busy working on my own project. I'm getting there though, I've had a chance to play about ten games.

[quote="Ashley":3da31hvy]Deadeye, can you send him a version of the game with the XAudio2 object deleted from all layouts and see if that works?[/quote:3da31hvy]

Yeah, I can do that. Gimme a few minutes here, I'm still getting my computer in order after the hard-drive crash so I have to reinstall Construct.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Mon Dec 01, 2008 1:30 am

Actually, I just made a small sample myself that plays a XAudio2 object and it crashed. So there's the problem. Thanks. :) I guess you don't need to make me that version anymore.

Now, how do I fix it?
B
1
G
4
Posts: 9
Reputation: 1,043

Post » Mon Dec 01, 2008 1:38 am

[quote="deadeye":kajqr6o4]Also, I didn't even know there were three Construct entries until you mentioned it.[/quote:kajqr6o4]
I didn't know that either until they all crashed in the same way. :) In fact, I wouldn't have even known about Construct if they didn't crash. I had seen something about Construct once before, but I didn't pay much attention.

[quote="deadeye":kajqr6o4]I haven't been able to keep up with the compo because I was so busy working on my own project. I'm getting there though, I've had a chance to play about ten games.[/quote:kajqr6o4]
There are some very good games there. I've played quite a few, but I'm particularly looking forward to playing yours. Yours has the most replies and the most views, so it's probably good. :)
B
1
G
4
Posts: 9
Reputation: 1,043

Post » Mon Dec 01, 2008 1:41 am

Wow I go away for two or three days and look what happens!

I'm going to have to try this out as soon as I get home! WEEEEEEEE!

~Sol
Tired of crappy file hosts that are crappy? Get DROPBOX - https://db.tt/uwjysXJF
Moderator
B
45
S
17
G
37
Posts: 2,853
Reputation: 25,966

Post » Mon Dec 01, 2008 2:06 am

Yes, dammit! Play my game or I will shove a didgeridoo up your aborigine ass and make you play the Star Spangled Banner.

Ew, on second thought... no I won't.

[quote="scytos":364wnq7x]Actually, I just made a small sample myself that plays a XAudio2 object and it crashed. So there's the problem. Thanks. :) I guess you don't need to make me that version anymore.

Now, how do I fix it?[/quote:364wnq7x]

Actually I think making a no-sound version would probably be a good idea so that folks who can't get it running even with the updates and stuff can play it.

Unfortunately, I have some sound-triggered events (is sound playing/is sound not playing) in the opening cutscene so it's messing up the order of the dialogue and stuff :P. It's going to take me a while to sort through it and fix it up, I haven't looked at the code for the opening cutscene in almost a month so I have no idea how to fix that mess :lol:
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Mon Dec 01, 2008 2:38 am

[quote="scytos":173b4e57]Actually, I just made a small sample myself that plays a XAudio2 object and it crashed. So there's the problem.[/quote:173b4e57]
Hmmm... you do have a sound card, right? Does it just crash straight away or does it crash when you try to play a sample?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,630

Post » Mon Dec 01, 2008 2:51 am

[quote="Ashley":276fvkf6]Hmmm... you do have a sound card, right? Does it just crash straight away or does it crash when you try to play a sample?[/quote:276fvkf6]
Right. It crashes straight away. I tried the two following things:
- Autoplay file using Directsound on left mouse button: plays sound ok after I click.
- Autoplay file using XAudio2 on left mouse button: crashes before I'm even able to click.
B
1
G
4
Posts: 9
Reputation: 1,043

Post » Mon Dec 01, 2008 3:14 am

Okay, got everything sorted out as far as a no-sound version goes.

Download: Right click/save as

Let me know if this works for you, scytos. And don't forget to comment in my compo thread :D

And I hope you can get Construct running, it really is a good program.
Moderator
B
5
S
2
G
6
Posts: 4,348
Reputation: 10,971

Post » Mon Dec 01, 2008 11:34 am

Yay, it works! Thanks. :)

But to be honest, I really want to play the version with sound, not to mention I'd like to play The Lake too. So I'll give it a few days to see if anyone around here can help me out - if not, I'll either play it without sound or find another computer to play it on. I played only the first scene, the graphics look really great.

But thanks for all the trouble of making that version. :)
B
1
G
4
Posts: 9
Reputation: 1,043

PreviousNext

Return to Your Creations

Who is online

Users browsing this forum: No registered users and 1 guest