My Zombies are overlapping each other

Get help using Construct 2

Post » Tue Jan 21, 2014 4:14 am

I have Zombies set to Solid:enabled, but they are still overlapping each other when they are coming after me. How do I make it so that they not only avoid being overlapped, but avoid bouncing off as well.

I also have this set on the zombies:
30 * dt
angle(ZombieEnemy.X, ZombieEnemy.Y, Player.X, Player.Y)
Check out my games on Google Play:
BEAST ATTACK (1,000,000+ downloads!)
ZOMBIE BASH (Android) (Launched Feb 17)
ZOMBIE BASH (iOS) (Launched March 17)
B
55
S
18
G
2
Posts: 436
Reputation: 5,607

Post » Tue Jan 21, 2014 5:04 am

the Solid behaviour collides with Platformer and Bullet but not other Solid.

When I had to deal with the same problem. I just gave them all bullet behaviours and the solid behaviour. It produced a bit of bouncing but managed to seperate them.
B
90
S
18
G
9
Posts: 2,455
Reputation: 15,028

Post » Tue Jan 21, 2014 6:51 am

What's odd is that I have both bullet and solid enabled on zombies. I do however have Line of Sight obstacles set to custom rather than solids.
Check out my games on Google Play:
BEAST ATTACK (1,000,000+ downloads!)
ZOMBIE BASH (Android) (Launched Feb 17)
ZOMBIE BASH (iOS) (Launched March 17)
B
55
S
18
G
2
Posts: 436
Reputation: 5,607

Post » Tue Jan 21, 2014 7:28 am

Oh. Found out that you have to set a speed to the bullet. Otherwise, it'll pass through objects.
Check out my games on Google Play:
BEAST ATTACK (1,000,000+ downloads!)
ZOMBIE BASH (Android) (Launched Feb 17)
ZOMBIE BASH (iOS) (Launched March 17)
B
55
S
18
G
2
Posts: 436
Reputation: 5,607


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 31 guests