Need help with camera positioning

For questions about using Classic.

Post » Tue Feb 16, 2010 4:40 pm

Okay, see the problem here?

About half of the screen is DIRT. That's unacceptable. We need to fix it, I don't know how to, but I assume you do.

Here's the .cap, could you please take a look and invent a good solution? I tried to make a separate camera, even positioning it above the player - the problem comes when you try to climb the tower upwards. Shift jumps, WSAD to move in the .cap.

Also, there's an EXTRA PROBLEM that nets you EXTRA RESPECT if you can help me with it.
There is a sword swinging animation. Sometimes it plays, most of the time it doesn't. Is there an event colliding with it? I've tried everything to fix it and it just doesn't like me.
Posts: 50
Reputation: 1,690

Post » Wed Feb 17, 2010 3:09 pm

Hey there Namelezz! Great to see that this project is still alive. I remember the first sword slashing videos. And what I see in the cap looks great!

As for your problem: all you do right now for scrolling is center view on the Hero sprite?!?!. If you just clamp the Y position of the camera to a certain position you'd have a really simple solution. Also I'd strongly suggest you start using the Advanced Camera plugin for this. It's really a great and incredibly useful plugin!

For a quick test I threw advanced camera in your cap and clamped it at 900 max. Looks like this:

I'll have a look at the sword thing you mentioned too, but as your cap is pretty complex it may take me a moment. :)
Posts: 1,015
Reputation: 7,420

Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 6 guests