Need help with movement animations

Get help using Construct 2

Post » Sun Dec 13, 2015 4:51 am

Hi all,

I just started learning Construct 2, and have been through some of the beginner tutorials. The following link is what I have managed to make at the moment (sprites and images taken either from the tutorials or from spriters-resource.com)

https: //drive.google.com/folderview?id=0B_aNwhmNZ_jKbVFSdDhsMDlVM0U&usp=sharing
(please remove the space after "https:" for the link. I'm not permitted to post it in full)

At the moment, there are 3 issues which I need help with:
1/ Player(Pichu):
I attached animations for 8 directions (for both "walking" and "not walking" states). Most of them seem fine, except the "walking" animations in diagonal directions (NE,NW,SE,SW) which appear to display only 1 frame (looks static) instead of 2.

2/Pichu attack animations:
I also pinned the attack animation to the 'movement' sprite (I planned for the move to be discharged AROUND the sprite). However, as it turned out, after being spawned, the move animation will stay there and fade. Is there any way to make it fade while still wrapped around the moving sprite?

3/ Enemy(Ekans):
I managed to execute the Waypoints method for AI movement as instructed in the tutorial. However, I am still struggling with Ekans's 8-direction animations since its movement is Bullet and not 8Directional. Could anyone please suggest what I can do to better manage Ekans' animations?

Thank you all in advance for your kind suggestions (and for being patient with my long post).
B
6
S
1
Posts: 14
Reputation: 328

Post » Sun Dec 13, 2015 7:22 am

Hey, I'm still looking through your capx. As far as your second question, though, scroll down to "Pichu Attacks". You have three actions. Make a fourth action and click "Pichumove", then click "Pin to Object", then pin it to "Pichu", and leave the mode as "Position and angle".

--EDIT-- Sorry, I meant to say Pin "Pichumove" to "PichuAnimation"
B
7
S
1
Posts: 10
Reputation: 347

Post » Sun Dec 13, 2015 7:37 am

Thanks for your suggestion.
Actually when I pinned it to "Pichu" it worked just as fine. After all, the animation is already pinned to the moving sprite I guess.
B
6
S
1
Posts: 14
Reputation: 328

Post » Tue Dec 15, 2015 5:31 am

Did anyone manage to figure out what was wrong with my events for point 1 and 3?
B
6
S
1
Posts: 14
Reputation: 328


Return to How do I....?

Who is online

Users browsing this forum: ismael123, MTR, tikuna and 12 guests