need immediate help with collider bug

Get help using Construct 2

Post » Wed Feb 05, 2014 4:44 pm

Hello!

My project is having major issues;
the playercharacter is sometimes stuck in the ground or in other obstacles, and I have no reason why. When I turn on the collision polys in the view-tab, I can see no problems, like gaps or strangely overlapping stuff. Sometimes the character is stuck even on plain ground, so I'm totally confused. (I'm pretty new to this software)
Even when I exchange the charactersprite or modify the colliders, the problem stays.
I've been asking friends that are familiar with construct, but no one could come up with an answer that fixed the problem.
I would like to know what other reasons this problem could have, apart from colliders.

I need to present my project tomorrow, so a fast reply would be awesome.

As I do not have any reputation yet, I'm afraid I can't post a link to my project here. If you need any further information, please tell me.
B
1
Posts: 2
Reputation: 129

Post » Wed Feb 05, 2014 4:56 pm

You can't post link, but you can post the URL (in text format).

Without more information, it could be anything.
B
17
S
8
G
4
Posts: 473
Reputation: 6,191

Post » Wed Feb 05, 2014 4:58 pm

It probably is your collision polygon.
If your polygon has different shapes on different animation-frames there is a good change that in one of those frames the polygon suddenly overlaps the ground and your player gets stuck.

To test this just go to the first frame of your animation and apply polygon to the whole animation.

It could onfcourse also be a misplaced origin point..
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Wed Feb 05, 2014 5:28 pm

Thank you very much for your fast replies!

The project is at https: //copy. com/boSahOOXk0FV
(I feel stupid now)

The collision polygon stays the same, as my playerbox is not animated. I pin the player object to it, but this has no behavior assigned to it. The origin is at the bottom of my playerbox.

Sometimes everything works fine, but then the character gets stuck even at places it has already been to. It's very confusing for me.

If you look at my project, please ignore layout 1 and 2, they were just tests.
Thanks again!
B
1
Posts: 2
Reputation: 129


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 43 guests