Need urgent help / workaround regarding object placement

Discussion and feedback on Construct 2

Post » Sat Jun 21, 2014 8:29 pm

Hi.

Already lost 3 - 5 hours of work today due to the strange placement of C2 objects in layers with different parallax.
Is there any workaround to this?

Currently C2 in a production pipeline eats time. Unnecessary time.
The red n black dot represents where the object is placed... where i click to place the object. On the far right, is where the object actually gets placed.
This occurs when parallax viewing is on in viewport.

Image
B
8
S
2
Posts: 163
Reputation: 1,115

Post » Sat Jun 21, 2014 8:58 pm

Select the layer, go to the properties pane on the left side of the screen, and change "Parallax in editor" to "No".
B
57
S
15
G
11
Posts: 912
Reputation: 12,606

Post » Sat Jun 21, 2014 9:03 pm

Not really a work around. I need to see the parallax effect to make sure object placement is correct.
B
8
S
2
Posts: 163
Reputation: 1,115

Post » Sat Jun 21, 2014 9:21 pm

So you want to be able to see where the object is placed according to its layer's parallax setting, but you don't want the object to appear in a way that's offset from where you placed it?
B
57
S
15
G
11
Posts: 912
Reputation: 12,606

Post » Sat Jun 21, 2014 9:27 pm

No...

I want to see the offset. I will report it as a bug.
I noticed some layers... when you place an object it places is 900 units to the right of where i placed it. Meaning i have to zoom out, look for the object because it was placed off screen, then drag it where i want it.

But then... other layers it places it exactly where i click. And then others at an offset at 200 etc.

Its a random placement.
B
8
S
2
Posts: 163
Reputation: 1,115

Post » Sat Jun 21, 2014 9:31 pm

Oh ok i see what happens. When parallax is enabled in viewport... the more you scroll to the right, the further it starts placing the objects.
By the time you reach the end of a 9000+ layout, the objects are places so far out of the screen that you have to zoom to 1.5% to just see the object to grab it and place it where it was meant to go.

Definitely a bug.
B
8
S
2
Posts: 163
Reputation: 1,115


Return to Construct 2 General

Who is online

Users browsing this forum: JaredX, megatronx and 2 guests