New audio plugin request

Discussion and feedback on Construct 2

Post » Wed Jun 26, 2013 9:50 pm

Hi Raiper341, I have similar problem as well:
NO SOUND: iOs 6 iPhone 4s
NO SOUND: Android 4.2.1 on Galaxy Nexus
YES SOUND: Chrome on Vista
YES SOUND: Firefox on Vista

All run through my server at: bringbabies.com/app/soundtest

To isolate problem, I used C2's own example of the side-scroll game template and only add a single music file.

To isolate audio file conversation problem, i created a m4a and a ogg myself then imported into the project.

If you want take a look and let me know if we have similar problems...
B
3
Posts: 1
Reputation: 202

Post » Wed Jun 26, 2013 10:19 pm

I used .vaw and i coverted to ogg and m4a trought construct 2 buildin exporter... So Self created m4a and ogg files do not wokr too....?
B
25
S
4
G
2
Posts: 318
Reputation: 2,501

Post » Wed Jun 26, 2013 10:29 pm

I can confirm that sound in chrome for android on nexus 7 has some issues, but instead of blaming Construct2 you should rather blame Chrome itself, since testing in the latest firefox for android version sound perfectly works (background music + sound FX) (tried on my game Drop da Piew in Scirra's arcade).

As far as cocoonJS goes, the sound in android works also as intended.

From the get go it has been clearly documented (throughout Scirra's blog) that sound support is a massive headache.
If the browsers don't implement the proper sound support, there's not much that can be done from Scirra's perspective.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
289
S
112
G
94
Posts: 7,333
Reputation: 69,287

Post » Fri Aug 02, 2013 1:14 am

I know this thread is getting old, but just to add to Kyatric's comment...

Chrome is great desktop browser but on Android device I have found it to be pretty useless.

I use Chrome on desktop, a Galaxy 10.1 Tablet (using latest Chrome beta), and also an iPad mini, for testing games.

One game I am working on:
Desktop: Solid 60 FPS sound always works.
Galaxy: 10-20 FPS and the sound mostly never works.
iPad mini: 55 + FPS and the sound always works!

So I think it is not C2 that is at fault....   michael2013-08-02 01:15:54
If it can be done, someone on the web will show you how to do it!

CDASI Games Mentality Break Splat-a-bug FlapFleet Challenge
B
34
S
12
G
7
Posts: 358
Reputation: 7,148

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 6 guests