New CocoonJS plugin from Ludei! Open source!

Discussion and feedback on Construct 2

Post » Tue Jul 29, 2014 8:10 am

igalencar wrote:
igalencar wrote:I still get the error on MoPub site over testing..
====================================== CAMPAIGN FILTER RESULTS ======================================
No adgroups for level 0.
No adgroups for level 1.
No adgroups for level 2.
No adgroups for level 3.
No adgroups for level 4.
No adgroups for level 5.
No adgroups for level 6.
No adgroups for level 7.
No adgroups for level 8.
No adgroups for level 9.
No adgroups for level 10.
Removed due to inactivity: AdMob key: 302ec62210e511e4abf3123138070049
No adgroups for level 11 passed filters.
No adgroups for level 12.
No adgroups for level 13.
No adgroups for level 14.
No adgroups for level 15.
Auction returning None

Does anyone is getting this?

anyone have solved this issue?


Well I had that same problem a few days ago and yesterday it suddenly wanted to work again.

My fillrate is >90% back to where it should be. So it was not working for a few days for whatever reason (probably Ludei or MoPub server backend).
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Wed Jul 30, 2014 10:57 am

Just a heads up for those unawares, CJS is not compatible with Xcode 6 beta.. I wasted days trying to troubleshoot this lame problem and its a problem with Xcode 6 beta and CJS conflicting.

The problem is that building a CJS project with XC6 add entitlements (permissions) "application ID, beta-access-group, keychain sharing" automatically to the IPA, which conflicts with your provisioning entitlements (since you dont have those and dont need it).

In Xcode5.1 (current version on the App Store), it does not have this problem.

But there's another problem, CJS version 2 or later, including 2.0.2 has a IDFA flag with Xcode so when you submit it to the App Store, they will email you asking why are you flagging Advertising code when your app doesn't have Ads? It turns out because CJS later versions include facebook & other SDK into their compiled build, this is flagging IDFA.

Seriously nearly threw my mac out the window with all the troubleshooting for the past few days.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Wed Jul 30, 2014 4:45 pm

i've had to hold off releasing 2 titles because of the issues with CocoonJS and ads and the missing html5.cpp or whatever error. It's extremely frustrating.
I'm generally not the type to get online and complain but seriously, how can I expect to get projects out and make revenue when I can't even get the stuff to work properly?

I think I'm stuck with waiting for a stable version of C2 or something because now my apps wont run on my phone after the Ludei logo. It just flickers and never loads... sdfasihadfn!!!
Image
B
73
S
21
G
9
Posts: 566
Reputation: 14,011

Post » Wed Jul 30, 2014 4:55 pm

Surprised to hear so many people having issues with ads and other things, my cocoonjs apps have been working well with ads and whatnot.

Also, good news, looks like they've almost got a fix for the "Restore purchase" issue:
https://github.com/ludei/Construct-2-pl ... t-50589616
B
63
S
12
G
6
Posts: 456
Reputation: 8,981

Post » Wed Jul 30, 2014 10:57 pm

After reading that some users had no problems with ads using 2.0.2 I decided to recompile my games but now is even worse. I only see a banner once every 10 game launches. I used the exact tutorial from AndreasR. I don't know...maybe there are no ads to show in my country at certain times. Can anyone test my game please https://play.google.com/store/apps/details?id=com.synapseone.pickastickfree
B
81
S
21
G
23
Posts: 515
Reputation: 18,702

Post » Fri Aug 01, 2014 2:34 am

They "depreciated" version 1.4.7 on their cloud compiler, I tried and it would not compile.

Way to annoy everyone because version 1.4.7 is actually the most stable.

YOU CANNOT EVEN SUBMIT APPS TO THE IOS APP STORE compiled with later versions because they included SDKs that flag IDFA advertising, your binary will be rejected for being invalid.

Way to go Ludei. Now I am pissed.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Fri Aug 01, 2014 2:54 am

Im getting nothing but Whitescreens when i test using Ludei,Im getting errors when i upload to Intel XDK.

This is really starting to get on my last nerve.I am trying to get a project to my friend/partner and i cant even come up with a stable build to play my freakin game.
Are we all supposed to just let our projects be dictated and ruined by 3rd party exporters,When in my honest OP i think scirra should have its own exporter.
This is just bull.Ive worked so hard and come to find out that i cant even play my game.I would understand if it was something i did on my part,but im being held back by 3rd party people that are not working on Construct 2.
GMO FOOD = DEATH
B
23
S
9
G
5
Posts: 567
Reputation: 6,378

Post » Fri Aug 01, 2014 3:22 am

RookieDev wrote:Im getting nothing but Whitescreens when i test using Ludei,Im getting errors when i upload to Intel XDK.

This is really starting to get on my last nerve.I am trying to get a project to my friend/partner and i cant even come up with a stable build to play my freakin game.
Are we all supposed to just let our projects be dictated and ruined by 3rd party exporters,When in my honest OP i think scirra should have its own exporter.
This is just bull.Ive worked so hard and come to find out that i cant even play my game.I would understand if it was something i did on my part,but im being held back by 3rd party people that are not working on Construct 2.


Yup, for C2 mobile developers we're going to be at the mercy of 3rd party wrappers for a long time yet.

But you can work with them (mostly), have you tested your game during development at major checkpoints on mobiles to see if they work well? Or you made the same mistake I did with my first game, build it all, finish, then find it doesn't work on CocoonJS and spend a lot of time fixing it.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Fri Aug 01, 2014 3:30 am

@Silverforce

Out of curiosity, is there a reason you are not using Ejecta for your iOS build?

Have you posted the issue on the github page? Seems to be the only place they pay attention to anything.
B
101
S
32
G
11
Posts: 1,546
Reputation: 21,667

Post » Fri Aug 01, 2014 3:30 am

@Silverforce i have tested on mobile ever since i started working on my project but it seems now that i want to build,It wants to give me issues.
I would love to use Ludei but i can not figure out why im getting the whitescreen,If i could get help on what the reasons that cause it,i could maybe narrow it down to why its happening.
Right now i can not get a game to play on mobile and it is very stressful.
I am very open to any feedback you have to offer,im at my wits end.
GMO FOOD = DEATH
B
23
S
9
G
5
Posts: 567
Reputation: 6,378

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 19 guests