New NW.js v0.18.0 doesn't work

Discussion and feedback on Construct 2

Post » Wed Oct 19, 2016 4:02 pm

I've also noticed there is a chrome menu appearing when right clicking on a button!
B
62
S
22
G
4
Posts: 357
Reputation: 6,478

Post » Wed Oct 19, 2016 4:22 pm

@Danwood I see that occuring as well on preview in the opera browser, might worth investigating
Game design is all about decomposing the core of your game so it becomes simple instructions.
B
52
S
22
G
18
Posts: 2,122
Reputation: 17,093

Post » Wed Oct 19, 2016 5:15 pm

--single-process is not an officially supported option, even Google only use it for testing purposes in Chrome. What are you using it for?
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Wed Oct 19, 2016 7:36 pm

Aphrodite wrote:@Danwood I see that occuring as well on preview in the opera browser, might worth investigating


I wonder if there's a way to fix it myself, or if we need to wait for a future NW update :roll:

UPDATE: seems like nightly build today fixed it! (and that's why i always update :P)
https://dl.nwjs.io/live-build/10-20-201 ... 6/v0.18.1/
B
62
S
22
G
4
Posts: 357
Reputation: 6,478

Post » Wed Oct 19, 2016 11:34 pm

Ashley wrote:--single-process is not an officially supported option, even Google only use it for testing purposes in Chrome. What are you using it for?

In order to get Steam features like Big Picture to work, without it users reported strange behaviors and even crashes.

The new 0.18.1 version was supposed to fix the use of the arg, I guess it's still broken.
Before creating a bug report on their git, I'd like to make sure that it's not just an issue on my end.
ImageImageImageImage
B
56
S
20
G
76
Posts: 634
Reputation: 43,357

Post » Fri Oct 21, 2016 2:01 am

I went out of my usual way and directly reported it to the NWjs team. (HERE)
I hope I've done it correctly and I'd appreciate a star/upvote to get this bug fixed as soon as possible.


Danwood wrote:I've also noticed there is a chrome menu appearing when right clicking on a button!

Scroll down and do the steps as mentioned in my post. (HERE)
ImageImageImageImage
B
56
S
20
G
76
Posts: 634
Reputation: 43,357

Post » Mon Oct 24, 2016 11:42 am

@TheRealDannyyy

Have you tried the more recent 0.18.2 to see if --single-process works?

https://dl.nwjs.io/live-build/10-24-201 ... 6/v0.18.2/

That arg is really handy for Steam, as it can bypass some issues as you reported, but also gets the overlay to be more reliable too.

I'm testing the OSX build and using the browser -> close to exit doesn't fully exit, game still runs in background and won't allow Steam itself to exit. Problems, problems!
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Mon Oct 24, 2016 3:00 pm

Silverforce wrote:Have you tried the more recent 0.18.2 to see if --single-process works?

My bugreport is still open and there was nothing about it being fixed in the changelog.

I don't like to install NWjs by myself anyway, I'd rather download Ashley's version here so I won't do any mistakes.
ImageImageImageImage
B
56
S
20
G
76
Posts: 634
Reputation: 43,357

Post » Mon Oct 24, 2016 3:21 pm

nw.js 0.18.2 still close with arg --single-process (win7-64 / nw.js0.18.2-x64)
Image Image
B
22
S
13
G
130
Posts: 869
Reputation: 67,816

Post » Mon Oct 24, 2016 11:22 pm

@MadSpy

Thanks. I dug through old topics about NWjs not closing properly and your name always came up. :)

Do you know if your Node Extended plugin works with MAC export? I'm having a problem with my MAC build on Steam, on close (Browser -> Close, or Window X, Command +Q etc) it exits the game but not fully. Steam thinks the game is still running so it cannot relaunch and Steam cannot quit due to an open process.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: AekiroStudio, Yahoo [Bot] and 13 guests