New NW.js v0.18.0 doesn't work

Discussion and feedback on Construct 2

Post » Tue Oct 25, 2016 8:55 am

@Silverforce , which OSX version do you use?
Image Image
B
22
S
13
G
135
Posts: 871
Reputation: 70,320

Post » Tue Oct 25, 2016 9:09 am

MadSpy wrote:@Silverforce , which OSX version do you use?


El Capitan.

I'll test it with Sierra tomorrow.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Wed Oct 26, 2016 6:42 am

@MadSpy

Tested the latest NWjs 0.18.3 build, with OSX Sierra.

The --single-process still crashes.

However, the exit problem with Steam no longer occurs, it correctly exits.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Wed Oct 26, 2016 6:56 am

@Silverforce

Do you try --single-process as command line instead of arg in package.json?
Image Image
B
22
S
13
G
135
Posts: 871
Reputation: 70,320

Post » Wed Oct 26, 2016 7:31 am

@MadSpy

Both. Node crash on launching with it.

Edit: And for some insane reason it's now not exiting properly again, game still runs using various methods to close it, including CMD + Q, Browser -> Close, Windows X etc.. I suspect it's Steam's overlay trying to inject itself into one of the nw process and this causes issues. Hopefully they fix --single-process arg soon, I'll test again then.

Edit2: Can confirm it's the Steam overlay injection. I disable overlay and the game exits just fine!
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Tue Nov 01, 2016 9:40 pm

I've tested the latest NW.js 0.19 beta1 and it works:
http://nwjs.io/downloads/

I've also niticed a CPU usage drop, can someone confirm it?
B
65
S
22
G
4
Posts: 358
Reputation: 6,555

Post » Tue Nov 01, 2016 9:43 pm

nw.js 0.19.0 beta is not stable.
Image Image
B
22
S
13
G
135
Posts: 871
Reputation: 70,320

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: David181 and 9 guests