[Newb] Construct keeps freezing

For questions about using Classic.

Post » Thu Dec 10, 2009 3:22 am

Hi everyone. I just downloaded construct and I was excited to use it so I started going through the tutorial, "Ghost Shooter", but every time I go to run the game it plays anywhere from 10-50 seconds before freezing. Sometimes the game will unfreeze, but for the most part that usually isn't the case. I have to Ctrl+Alt+Del and end the task. I tried making another game with just a square that moved with the mouse thinking maybe it had to do with the 8direction movement, but no luck. I'm running Windows XP professional and I have a dual core processor.
B
3
G
3
Posts: 23
Reputation: 946

Post » Thu Dec 10, 2009 3:39 am

What video card do you have, and how much memory? And do you get any error messages, and if so, what are they?
B
3
S
2
G
3
Posts: 628
Reputation: 2,531

Post » Thu Dec 10, 2009 4:02 am

ATI Radeon HD 4830 512 MB. 2g DDR2 Ram. No error messages, just hard freezes.
B
3
G
3
Posts: 23
Reputation: 946

Post » Thu Dec 10, 2009 8:17 am

Hmm, do any of your other DirectX apps/games crash too, or is it just construct? Is it the exe it creates that crashes, or temp.exe when you do a test in the program? Can you at least run the program, create something, or does it crash during that too?

I'm sure someone else will be able to offer more help, best I can suggest is reinstalling it and make sure DirectX is installed and updated as needed too.
B
3
S
2
G
3
Posts: 628
Reputation: 2,531

Post » Thu Dec 10, 2009 9:49 am

Never heard of this before. I would suggest ensuring your graphics card drivers are up-to-date and seeing if that helps.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Thu Dec 10, 2009 9:43 pm

[quote="Lost my Keys":vyoli8v9]Hmm, do any of your other DirectX apps/games crash too, or is it just construct? Is it the exe it creates that crashes, or temp.exe when you do a test in the program? Can you at least run the program, create something, or does it crash during that too?

I'm sure someone else will be able to offer more help, best I can suggest is reinstalling it and make sure DirectX is installed and updated as needed too.[/quote:vyoli8v9]

I'm not sure what games I have on here that are using DirectX, but I don't recall any games crashing on me. It's both the exe and the temp.exe that freeze up. I can run and create something fine with no problems. It's only when I try to test it or run it that I have a problem. I'll try reinstalling and making sure my drivers are up to date and get back to you.
B
3
G
3
Posts: 23
Reputation: 946

Post » Thu Dec 10, 2009 9:56 pm

[quote="Jonathan5":lrsj9nzx][quote="Lost my Keys":lrsj9nzx]Hmm, do any of your other DirectX apps/games crash too, or is it just construct? Is it the exe it creates that crashes, or temp.exe when you do a test in the program? Can you at least run the program, create something, or does it crash during that too?

I'm sure someone else will be able to offer more help, best I can suggest is reinstalling it and make sure DirectX is installed and updated as needed too.[/quote:lrsj9nzx]

I'm not sure what games I have on here that are using DirectX, but I don't recall any games crashing on me. It's both the exe and the temp.exe that freeze up. I can run and create something fine with no problems. It's only when I try to test it or run it that I have a problem. I'll try reinstalling and making sure my drivers are up to date and get back to you.[/quote:lrsj9nzx]

If it asks to install DirectX (I think construct does when installing) let it. I noticed that even though I had it all installed correctly, some games (The Maw being one I remember) just plain refused to work correctly without letting it install or at least check the installation of it. So could be that?
B
3
S
2
G
3
Posts: 628
Reputation: 2,531

Post » Thu Dec 10, 2009 11:38 pm

My graphics card drivers are up to date. I have DirectX 9, but I updated anyways. Reinstalled Construct, but to no avail. Still isn't working :| I don't believe it has anything to do with DirectX because when I try to make a regular app it still freezes.
B
3
G
3
Posts: 23
Reputation: 946

Post » Thu Dec 10, 2009 11:55 pm

[quote="Jonathan5":2b88bo7l]My graphics card drivers are up to date. I have DirectX 9, but I updated anyways. Reinstalled Construct, but to no avail. Still isn't working :| I don't believe it has anything to do with DirectX because when I try to make a regular app it still freezes.[/quote:2b88bo7l]

Hmm, I don't know what it could possibly be then. Isn't there a way to set windows to record crash logs somewhere? I've never used it, or XP so wouldn't know where to find it. But maybe it would have something in there that could at least give the devs or somebody, an idea why it's happening.

You could always try testing your drive(s) and memory, see if there's a problem with those. Or maybe checking the runtime files are being installed correctly, could be a problem with those too?

Sorry, it's really hard to say what it could be, there's nothing much to go on. :\
B
3
S
2
G
3
Posts: 628
Reputation: 2,531


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 6 guests