newbie animation problem

For questions about using Classic.

Post » Tue Jan 25, 2011 10:36 pm

hi, thanks scirra for making such a great tool for free.
i started to make a great platformer, but for starters i wanted to learn to animate my self with the tutorial sprites.
so i took the sprite from the platform school. but there is a bug thats making me shave my hair from angst.

when i jump and i fall, when my char hits the ground the fall animation dosnt stop, so he continues to flicker between fall and stand. and yes all the hotspots are the same. i dont know what is, i tried everything and its MAKING ME MAD.

can someone PLEASE HELP ):

http://kplusm.net/WELP.cap
http://kplusm.net/WELP.persist

here are the files i hope someone can help me,i lost two hours trying the damn animations to actualy play and now this...
B
3
S
1
G
1
Posts: 141
Reputation: 1,007

Post » Tue Jan 25, 2011 11:00 pm

Im new to the whole program aswell, but have you made an animation and used the "stopped" tag on the animation ?

I had that problem aswell before I used the "Stopped". As a "idle" pose.
B
1
G
1
Posts: 6
Reputation: 437

Post » Tue Jan 25, 2011 11:05 pm

thanks so much for helping, ill try it now and see if it works! :D

it seems there are atleast two ways to animate a platform
1 - the platform school tutorial -> when player walks animate walking
2 - when player presses right animate walking

i still dont get the tags but it has to work
B
3
S
1
G
1
Posts: 141
Reputation: 1,007

Post » Tue Jan 25, 2011 11:08 pm

Im linking the tutorialthingie i looked at when i did my movementthing.

http://www.youtube.com/watch?v=y9vs494u4Ik

There ya go.
B
1
G
1
Posts: 6
Reputation: 437

Post » Tue Jan 25, 2011 11:13 pm

ah this is great, and its alot more of a new way compared to what i was trying wow
thanks
B
3
S
1
G
1
Posts: 141
Reputation: 1,007

Post » Tue Jan 25, 2011 11:14 pm

No problem this was a problem I could assist with, more advanced stuff Im not really sure i can assist anyone with yet.. Im still working on my first project myself.
B
1
G
1
Posts: 6
Reputation: 437

Post » Tue Jan 25, 2011 11:33 pm

o my god, i followed every step and it dosnt work with me.
the char keeps walking at one place, stucking on fall animation when he reaches the ground.
awful....im going nuclear with rage
B
3
S
1
G
1
Posts: 141
Reputation: 1,007

Post » Tue Jan 25, 2011 11:35 pm

ah..i taged idle as stopped and now everything works allright.
wow....thank the gods its finnaly over. i can finnaly continue [solved]
B
3
S
1
G
1
Posts: 141
Reputation: 1,007

Post » Tue Jan 25, 2011 11:35 pm

*edit*

Ah nice that you solved it. Now make some awesome games!
B
1
G
1
Posts: 6
Reputation: 437


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests