No Internet Connection

For educators around the world who use Construct 2 in classrooms

Post » Mon Feb 16, 2015 9:30 pm

In an educational setting we often run with the Internet disabled but a local WIFI network for testing. In this situation sometimes C2 takes more than 1 minute to open up. Is this normal?
B
7
S
3
Posts: 23
Reputation: 925

Post » Tue Feb 17, 2015 12:11 am

No, C2 shouldn't need any Internet access to be able to start up. Are you sure it's the Internet availability that's causing the problem?
Scirra Founder
B
383
S
225
G
86
Posts: 24,122
Reputation: 190,567

Post » Tue Feb 17, 2015 12:44 am

All I can say is that when connected to the Internet, C2 starts normally on these machines with no delay. I can find no other reason/variable for the long startup time.
B
7
S
3
Posts: 23
Reputation: 925

Post » Tue Feb 17, 2015 9:08 am

you need a internet connection only when you run on local port such as 192.168.1.1 : 50000 but even then it should not need internet but a firewall port opened for C2 to run, instead of localhost:50000 if u use the 192. port just change the settings for preview on localhost as it is default C2.

another thing that can cause that, is having java script outdated or flash player plugin the bugged one in beta that is now latest(pepper flash) its kinda creating problems i had same issues a few times with my previews its possible also to be the browser not being updated . hope it helps. but as Ashley said it shouldn't need any internet connection since its running on local host, that is your default network connection.
B
70
S
20
G
67
Posts: 1,311
Reputation: 42,284

Post » Tue Feb 17, 2015 4:22 pm

Why do you need an Internet connection when running on a local port and IP?

We use static IPs for all machines on a local wifi network with all firewalls disabled since there is no outside connection. This allows students to easily find the IP address from the development machine's browser window to enter on an iPad for mobile testing. I know it can be changed in the C2 preferences but it is problematic for a large class - 30 students. The whole goal is to make it as easy as possible to for the students to preview on a mobile device as well as locally.

BTW, the problem is not delayed/slow previewing but very slow C2 startup. Previewing works fine as long as the local browser is open before previewing is initiated in C2.
B
7
S
3
Posts: 23
Reputation: 925

Post » Wed Feb 18, 2015 11:50 am

ctceismc wrote:Why do you need an Internet connection when running on a local port and IP?


You don't and it is totally unrelated. Same as having outdated flash player doesn't impact C2 at all, it just impacts your browser and shouldn't be an issue when previewing HTML5 anyway.

All I can think of for the low startup is the startup page of C2 since it is based on IE.
Make a test, disable the startup page from the preferences, disable the WI-FI and launch C2 again.
Do you see an improvement ? If you do, it is safe to assume it is the lack of internet that slows down IE's browser and C2's startup page as such.
If you can spare that startup page, remove it from the preferences and you shouldn't have issues any more.
New to Construct ? Where to start

Image Image

Image Image

Please attach a capx to any help request or bug report !
Moderator
B
276
S
103
G
84
Posts: 7,289
Reputation: 83,098

Post » Wed Feb 18, 2015 6:58 pm

Could it be the "update checking" thing that tries in vain to see what's the latest version on scirra.com ?
B
62
S
26
G
24
Posts: 954
Reputation: 18,318


Return to Education and Construct 2

Who is online

Users browsing this forum: No registered users and 1 guest