No sound on ipad

Get help using Construct 2

Post » Sun Dec 02, 2012 10:15 pm

Hello, (i'm french excuse my english)

I exported html5 page and on ipad 1 & 2 with safari (version default when buy it) there is no sound.

In directory media i have .m4a and .ogg.

On the web i see the .m4a is supported by the ipad.

it's true ?

why it does not work ?


why construct 2 not export .wav 96kbps in media for more compatibility.
I know .wav is a heavy format but choose in optional the sound format to the export html5 be practical.

example : i want .wav .ogg for this export and
.m4a and .wav for an other game.

Thank you.
B
11
S
3
Posts: 133
Reputation: 1,926

Post » Mon Dec 03, 2012 1:31 am

.WAV doesn't play in most browsers, AAC and OGG cover all browsers in common use.

You need to make sure your server supports the correct MIME types for .m4a (audio/mp4), otherwise some servers return 404 Not Found for unknown file types. If that doesn't fix it, share your URL so we can take a look.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,610

Post » Mon Dec 03, 2012 11:50 pm

I test with construct 2 the export html 5 and if the software covers all my needs I would buy a license soon.

The page http://www.lapetitehistoiredusoir.com/html5/hist/index.html

on PC sound ok with mozilla chrome opera...

on Ipad 1 & 2 with safari (default when buy it) there is no sound.

if i paste the link of the sound on pc it works.

http://lapetitehistoiredusoir.com/html5/hist/media/sorcieres_naiment_pas_le_rose96k_1.ogg

http://lapetitehistoiredusoir.com/html5/hist/media/sorcieres_naiment_pas_le_rose96k_1.m4a

Do you think it's type MIME on the server ?chrislechat2012-12-04 00:23:15
B
11
S
3
Posts: 133
Reputation: 1,926

Post » Tue Dec 04, 2012 1:16 am

delete .ogg files on media folder
B
96
S
25
G
20
Posts: 3,055
Reputation: 22,646

Post » Tue Dec 04, 2012 5:33 pm

for test I'll delete the .ogg but if it's work with that i lose my
my compatibility with other browsers.

On the ipad 1 & 2 with safari i tested the arcade game on the website scirra.com and there is no sound.

So this is not a problem MIME type on my server.


why it's not working whereas .m4a is supported by safari on ipad ?


B
11
S
3
Posts: 133
Reputation: 1,926

Post » Wed Dec 05, 2012 9:12 pm

I tested my link :

http://www.lapetitehistoiredusoir.com/html5/hist/index.html

with .ogg deleted on ipad and it does not work.



I put sounds on my server for test .ogg and m4a.

i paste the link :

http://www.lapetitehistoiredusoir.com/html5/hist/media/1.m4a

on ipad (safari) the sound is played in the browser.
on PC with mozilla the sound is played in the browser.


i paste the link :

http://www.lapetitehistoiredusoir.com/html5/hist/media/1.ogg

on ipad (safari) the sound is not played.
And the browser say : Do you want to download

on PC with mozilla the sound is played in the browser.

If on PC mozilla play the 2 formats .ogg and .m4a so this is not the MIME type of the server. isn't it ?

how to make the exports html 5(with sound) works on ipad ?

Thank you for your help.



B
11
S
3
Posts: 133
Reputation: 1,926

Post » Wed Dec 05, 2012 11:15 pm

That's odd, would you share your .capx to investigate?
B
96
S
25
G
20
Posts: 3,055
Reputation: 22,646

Post » Thu Dec 13, 2012 3:17 pm

Hello,

i tried many things and i do not understand.
Why sound does not work on ipad (PC works)?

capx and link with .ogg deleted on server :

http://lapetitehistoiredusoir.com/html5/hist/capx/no_sound_on_ipad_story.capx

http://lapetitehistoiredusoir.com/html5/hist/index.html


if perhaps it is due to the "on ended" why the sound not start "on start layout" ?

A question : what that is loaded with the basic loader html5 ?

perhaps a preloader sound is mandatory ?

Thank you for your help.   
B
11
S
3
Posts: 133
Reputation: 1,926

Post » Thu Dec 13, 2012 3:38 pm

@chrislechat - if I visit this URL:

http://www.lapetitehistoiredusoir.com/html5/hist/media/1.m4a

I get a "Not found" error. That might be why audio isn't playing, are you sure you uploaded the files and have the correct MIME type set?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,610

Post » Fri Dec 14, 2012 8:15 am

Hello,

today the sound 1.m4a is not used, the link is old.
This is another new test

Today the valid link are :

the first sound in the project on start layout is :

http://www.lapetitehistoiredusoir.com/html5/hist/media/sorcieres_naiment_pas_le_rose96k_1.m4a

and link .capx

http://lapetitehistoiredusoir.com/html5/hist/capx/no_sound_on_ipad_story.capx

thank you.
B
11
S
3
Posts: 133
Reputation: 1,926

Next

Return to How do I....?

Who is online

Users browsing this forum: No registered users and 28 guests