Node-webkit audio looping issue

Bugs will be moved here once resolved.

Post » Sat Feb 16, 2013 6:10 pm

Link to .capx file (required!):
https://dl.dropbox.com/u/20803261/NWTest.capx

Steps to reproduce:
1. Go to this link https://dl.dropbox.com/u/20803261/NWTest/index.html and load the game in any browser. You can also use the preview option in Construct (F4).
2. Download the .capx file and export the project with node-webkit.

Observed result:
On any browser, the audio plugin will detect appropriately if a looping sound is already playing and won't restart it again every time we go back and forward.

However, if we try the node-webkit version (win32), it's obvious that the loops get stacked when we return to the first layout after pressing the GO - BACK buttons, resulting in several instances of the same audio playing at the same moment, therefore altering the whole experience.

Expected result:

Node-webkit detects the looping sounds already playing and ignores the stated order of playing it again at the start the layout (for example, when navigating through menues).

Browsers affected:

Operating system & service pack:
Windows 7 64bit

Construct 2 version:
r119JGPicatoste2013-02-18 14:46:03
B
32
S
8
G
2
Posts: 31
Reputation: 4,256

Post » Mon Feb 18, 2013 12:41 pm

The link to your .capx is not working. Can you fix it?
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Mon Feb 18, 2013 2:45 pm

@Ashley

FixedJGPicatoste2013-02-18 14:56:34
B
32
S
8
G
2
Posts: 31
Reputation: 4,256

Post » Wed Feb 20, 2013 2:45 pm

Thanks, should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests